WP8548 stuck in init process


#1

I tried to start my python application by adding it into /etc/init.d/ and after reboot it i have lost my linux access of module.

now even i am unable to ssh on module by ethernet port as well before it was providing facility to share internet to module.

here is network information of host.

USB host
enp0s20f0u3i19 Link encap:Ethernet HWaddr c2:95:9c:f9:c1:e3
inet addr:192.168.2.3 Bcast:192.168.2.3 Mask:255.255.255.255
inet6 addr: fe80::5c6f:73cc:290e:aea6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:536 (536.0 B) TX bytes:5079 (5.0 KB)

etherenet host
enp0s31f6 Link encap:Ethernet HWaddr c8:5b:76:4e:f2:20
inet addr:10.42.0.1 Bcast:10.42.0.255 Mask:255.255.255.0
inet6 addr: fe80::b14f:a7ee:8ce7:f9ff/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:89 errors:0 dropped:0 overruns:0 frame:0
TX packets:4393 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21976 (21.9 KB) TX bytes:332119 (332.1 KB)
Interrupt:16 Memory:f1200000-f1220000

i am not able to find module ip in case of usb host .

gp-umesh@gpumesh:~$ nmap -sP 192.168.2.1/24
Starting Nmap 7.01 ( https://nmap.org ) at 2017-06-15 13:02 IST
Nmap scan report for 192.168.2.3
Host is up (0.00037s latency).
Nmap done: 256 IP addresses (1 host up) scanned in 5.64 seconds

but in case of eth cable host

gp-umesh@gpumesh:~$ nmap -sP 10.42.0.1/24
Starting Nmap 7.01 ( https://nmap.org ) at 2017-06-15 12:47 IST
Nmap scan report for 10.42.0.1
Host is up (0.00089s latency).
Nmap scan report for 10.42.0.98
Host is up (0.00077s latency).
Nmap done: 256 IP addresses (2 hosts up) scanned in 5.01 seconds

and I can ping the module

gp-umesh@gpumesh:~$ ping 10.42.0.98
PING 10.42.0.98 (10.42.0.98) 56(84) bytes of data.
64 bytes from 10.42.0.98: icmp_seq=1 ttl=64 time=0.838 ms
64 bytes from 10.42.0.98: icmp_seq=2 ttl=64 time=0.690 ms
64 bytes from 10.42.0.98: icmp_seq=3 ttl=64 time=0.579 ms
64 bytes from 10.42.0.98: icmp_seq=4 ttl=64 time=0.877 ms
64 bytes from 10.42.0.98: icmp_seq=5 ttl=64 time=0.990 ms

But still i am unable to login to module
gp-umesh@gpumesh:~$ ssh -v root@10.42.0.98
OpenSSH_7.2p2 Ubuntu-4ubuntu2.2, OpenSSL 1.0.2g 1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 10.42.0.98 [10.42.0.98] port 22.
debug1: connect to address 10.42.0.98 port 22: Connection timed out
ssh: connect to host 10.42.0.98 port 22: Connection timed out

i am able to communicate with AT commands over USB2.

ATI

Manufacturer: Sierra Wireless, Incorporated
Model: WP8548
Revision: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
IMEI: 359377060004834
IMEI SV: 43
FSN: LL536500061203
+GCAP: +CGSM,+DS,+ES

OK
AT!MAPUART?

!MAPUART: 17,16

OK

please help how to resolve issue to get normal ssh login into module again.


#2

You could use fdt or swiflash to install a default system. That obviously involves overwriting your existing system, so that could be problematic if you are worried about losing the existing configuration of the device.


#3

I tried Swiflash -r to restore it. but still same thing are there.

(conc) gp-umesh@gpumesh:~/yocto/build_bin/tmp/deploy/images/swi-mdm9x15$ swiflash -m WP85XX -i yocto_wp85.cwe
Detecting USB of the target
DONE
Communicating with the target
DONE
Switching to firmware download mode
…DONE
Downloading the firmware
…DONE
Rebooting the module
…DONE
Firmware Download SUCCESS

i am still unable to login to module.

even i tried the fastboot commands
but it says only

(conc) gp-umesh@gpumesh:~/yocto/build_bin/tmp/deploy/images/swi-mdm9x15$ sudo fastboot flash kernel boot-yocto-mdm9x15.2k.img
< waiting for device >

and fastboot devices returns nothing.

(conc) gp-umesh@gpumesh:~/yocto/build_bin/tmp/deploy/images/swi-mdm9x15$ sudo fastboot devices
(conc) gp-umesh@gpumesh:~/yocto/build_bin/tmp/deploy/images/swi-mdm9x15$

how can i reflash linux that can rebuild fresh /etc/ directory in module again?


#4

below is the restore command reply.

(conc) gp-umesh@gpumesh:~/yocto/build_bin/tmp/deploy/images/swi-mdm9x15$ swiflash -m WP85XX -r
Detecting USB of the target
DONE
Communicating with the target
DONE
Downloading the firmware
.DONE
Rebooting the module
…DONE
Firmware Download SUCCESS

but still case is same.
i am unable to get ssh login access.


#5

Only one interface you can use for Legato version16.10.0 or newer

However, I could not ssh into the board via Ethernet with the mangOH green system file (.sdf) and I have to communicate with the board using serial adaptor and switch back to USB port. See details here:

Hope this helps.