WP7702 Crashed and Installed app is gone

I’m using a WP7702. Please see following snippet for Firmware versions:

My issue is that I have a modified version of the Asset Data Application where I have basically just added a few more variables / commands and exposed the UART to this app so that I can communicate to another micro-controller off the MangOH Red board.

During testing of my application, I set it to autostart, so that it would run on power on. The WP7702 was collecting data from UART, and sending updates to AirVantage every 10 minutes.

The MangOH was left powered on and running for about a week. All was good and I was reliably getting data to the dashboard until the end of the week - I stopped getting updates to the dashboard. No new data sessions occurred from this point on.

Upon plugging into the CF3 USB and checking “app status” command, the Asset Data app that I had installed was gone. Not sure if something like a watchdog reset the legato OS, or if the legato OS purged the app because something went wrong.

Can someone point me to something I can look at such as a log, or a better understanding on how I can implement some sort of fail-safe to guard against the app disappearing?

I would like to further understand what actions can be taken to ensure this sort of issue can be mitigated and how it happened at all.

There is rollback mechanism, you need to use “update -g” to mark good system after install the app



Thank you for the reply, I did see this page when researching the issue.

I saw the section below:

“Once the probation timer expires, (the default being 30 minutes,) the new system is marked good.”

The way I interpreted this was that after 30 minutes of having the new app installed, the system automatically is marked as good. Given the system was operating for over a week, I thought that the probationary timer had been reached.

I will explicitly use this command if that’s what we need to do. Do you know if there is a command to tell me the state of the system good flag? In other words, Can I tell if the system has been marked good or not?

Can I also check to see if my system is using the default 30 minute timer for the probationary timer?

Thank you for your help.

You can use “legato status” to see if system is marked good

I have tried using this command in the following two scenarios with the same result each time.

  1. Well after the 30 minute probationary period >6 hours.
  2. A few minutes after installing new application and rebooting.

Each time I get the same result below:


Does this mean that my system is not even entering probationary period?

Did you type update -g

No I did not. How can I check the default probationary period? How do i know if it is set to 30 minutes?

it is working as expected on my side:

root@swi-mdm9x28-wp:~# legato status
Systems installed:
127 [good] ← current
Legato framework is running.
root@swi-mdm9x28-wp:~# update /tmp/modemDemo1.wp76xx.update
Unpacking package: 100% ++++++++++++++++++++++++++++++++++++++++++++++++++
Applying update: 100% ++++++++++++++++++++++++++++++++++++++++++++++++++
root@swi-mdm9x28-wp:~# legato status
Systems installed:
127 [good]
128 [tried 1] ← current
Legato framework is running.
root@swi-mdm9x28-wp:~# legato version

Thank you, I am familiar with the process for setting the system as good by using the command update -g.

What I would like to know is how to check the duration of the probationary period. The documentation says default 30 minutes.

I would like to see what my WP7702 is currently set to?

You can install a helloworld and check the legato status after 30 minutes

So there is no command to check the probationary time? I just have to time it myself and see what it is?

Does that also mean there is no way to change the probationary time?

You can see here