WP7607 - UART1 doesn't work

Hello there! :slight_smile:
I hope you can help me…

I have developed a own simple modem with the WP7607 module.
My designe with the WP7607 is almost completely working.
There is just one problem…
I can’t establish a connection over UART with the modul. There is just no response from the WP7607 when i send them AT-Commands.

Everything else what i need is working. > SIM-Card detect, WAN connection … and also talking with the module over USB by use of AT-Commands!
… just the UART1 isn’t working.

I have connect: UART1_RX ; UART1_TX ; UART1_CTS ; UART1_RTS (all come or go to a level-shifter [1,8V >< 5V])
… UART1_CTS and UART1_RTS is connected togehter after the level-shifter.
I don’t have connect: UART1_DSR ; UART1_DCD ; UART1_DTR ; UART1_RI (all floating)

I don’t understand where is the problem…
Does i need to configure the UART1 over some AT-command at first?

Many thanks for your effort! :slight_smile:
Hope somebody has an interesting idea… :slight_smile:

what is the AT!MAPUART? in USB AT command port?
There should not be problem to use UART1 to enter AT command after setting AT!MAPUART.

You can see here:

Hey jyijyi,
thanks for your fast respone! :slight_smile:

I got following:


!MAPUART: 1,16


Manufacturer: Sierra Wireless, Incorporated
Model: WP7607-1
Revision: SWI9X07Y_02.18.05.00 000000 jenkins 2018/07/19 17:40:21
IMEI: 359780081347738
FSN: V2052185181010


I gues the Firmware is very old, but currently i dont have the courage to update this, just cause the old original Firmware on this module (from 2018) isn’t available any more.

also this:


+IPR: 115200

Serial port speed is set to 115200.

Legato Ver: 18.06.3_dc55d84226223a3798b01c1a272e9603
Yocto Ver: SWI9X07Y_02.18.06.00 2018-09-20_16:17:38
OS Ver: Linux version 3.18.44 (jenkins@jenkins) (gcc version 6.2.0 (GCC) ) #2 PREEMPT Thu Sep 20 16:20:02 UTC 2018
LK Ver: SWI9X07Y_02.18.06.00
RootFS Ver: SWI9X07Y_02.18.06.00 2018-09-20_16:17:38
UserFS Ver: unknown
MCU Ver: 002.009


Can you try R13 as it has been proven to be working fine?

I have flash R13 and R16 now but still no UART1…
I guess there is still a little hardware problem, no problem with the UART it self…
but possibly something like a bad powerup of the module or so…
makes no sense to me, especially because the the other things are running

you can use oscilloscope to see if there is any signal.

I have look at the Signals already… there where fine.
[1,8V in idle > UART typical]
the module gets the data but sends nothing back.

Is there a AT-command to show and set if RTS/CTS on or off?

you can use AT+IFC?

but i wonder how can you check if it does not respond to any AT command

BTW, maybe you need to try different baud rate

OK! Thanks! I have try…
No flow control on Terminal Equipment(TE) side ie Host Device.
No flow control on Terminal Adapter(TA) side ie Modem.
so should all be fine…

I have already try 9600, 19200, 57600, 115200 kbaud all with parity none and even.

I talk to the module over USB (whats is UART too).
Does this mean, that the readout of the settings of the UART ( at!mapuart? and AT+IPR?) are just for the USB-UART or are these settings for all UARTs including UART1 ?

I have done some interesign experiment…

On this side there is a nice overview of the AT!MAPUART command…

I have set UART1 (my problem UART) as output for the Linux Console (with AT!MAPUART= 16,1)

While bootup of the module, the module now shows his complete boot process in my terminal.
(You can see here)
WP7607 Booting !MAPUART 1,16 Linux Console.txt (14.2 KB)

So the transmitt hardware of the WP7607 is working perfectly.
Iam also shure that, the receive hardware to the module is working.

will you consider to enter AT command with console mode by “microcom /dev/ttyAT”?

BTW, have you tried enable flow control on your host side?

sadly i dont have linux … microcom is ubunty right?
but i can try tomorrow!

No i dont have try to anable flow control!
can you tell me the right AT command?

"microcom " is used in WP76 linux console!

When you open the UART in windows, you should be able to choose if you enable flow control, then you can try both option.

one thing i have to correct… my problem UART is UART0 !
UART1 is not connected…
its confusing cause in the schematics everywhere there stands UART1 and UART2

ah ok… you talk about the flow control on the host side (windows) … yes i have try allready.

i go creazy with that problem… :wink:

many many thanks for your effort till now jyijyi! :slight_smile:

I will try to use UART1 (UART2 in schematic) now!
possibly this UART will work with AT-commands…

The first UART0 has also this DSR / DCD / DTR / RI Pins… (not shure what they so)
and i’am not shure if there is some problem in my case…

I let you know after this test

no… sadly no good idea! UART1 (UART2 in schematic) is not settable as AT Command Interface!

What i have seen with the old UART0 is following…
When i send some command like “AT” the first time, than the module response nothing.
When i send shortly after that first command a second command, the module gives exactly the same back.
I doesnt have to be a AT command… could also be something like “Hello1234”!
… the module sends the same after the second try back to me…

Not quite really understand what you are talking about uart0 uart1 uart2 …

Are you using mangoh board?

If you can use uart2 as linux console, you can enter AT command by “microcom /dev/ttyAT”

No i dont use a mangho board. I have developed my own little pcb referring to the Mangho red board.
The WP7607 has two hardware UART Pinouts.
(a third software UART is over USB, what i use for tests to communicate with the module)
This both hardware UARTs are in Software UART0 and UART1.
But in Hardware is the labeled UART1 and UART2. (in the Mangho red schematic too)
You can see here on Page 2 the WP7607 module.
Pin2 - Pin9 is UART1 ; Pin96 - Pin99 is UART2

And sadly UART2 ist able to configure to AT-command Interface.
When i give the modeule the AT-command to set UART2 to AT-Inferface, it gives just “error” back.

I don’t see problem to enter AT command in UART2 where it is set to be console mode:

Poky (Yocto Project Reference Distro) 2.5.2 swi-mdm9x28-wp /dev/ttyHSL1

swi-mdm9x28-wp login: root

root@swi-mdm9x28-wp:~# microcom /dev/ttyAT
Manufacturer: Sierra Wireless, Incorporated
Model: WP7609
Revision: SWI9X07Y_02.28.03.03 000000 jenkins 2019/05/21 03:33:04
IMEI: 359782080100399
FSN: WA803370010610

Current Time:  50               Temperature: 35
Modem Mitigate Level: 0         ModemProc Mitigate Level: 0
Reset Counter: 1                Mode:        LOW POWER MODE

+CFUN: 0