WP7603 cdc_ether probe error -22


#1

Hi,

I am trying to get WP7603 going on a board, but when the USB is connected, the interface does not come up - getting “cdc_ether: probe of 1-9.5.2:1.19 failed with error -22”

Does anyone have any pointers?

Thanks!

[4756543.860998] usb 1-9.5.2: new high-speed USB device number 64 using xhci_hcd
[4756543.953946] usb 1-9.5.2: config 1 has an invalid interface number: 8 but max is 5
[4756543.953948] usb 1-9.5.2: config 1 has an invalid interface number: 19 but max is 5
[4756543.953949] usb 1-9.5.2: config 1 has an invalid interface number: 20 but max is 5
[4756543.953950] usb 1-9.5.2: config 1 has an invalid interface number: 20 but max is 5
[4756543.953951] usb 1-9.5.2: config 1 has no interface number 1
[4756543.953952] usb 1-9.5.2: config 1 has no interface number 4
[4756543.953953] usb 1-9.5.2: config 1 has no interface number 5
[4756543.961926] usb 1-9.5.2: New USB device found, idVendor=1199, idProduct=68c0
[4756543.961928] usb 1-9.5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[4756543.961929] usb 1-9.5.2: Product: Sierra Wireless WP7603-1
[4756543.961930] usb 1-9.5.2: Manufacturer: Sierra Wireless, Incorporated
[4756543.961931] usb 1-9.5.2: SerialNumber: 567a58
[4756543.963177] option 1-9.5.2:1.0: GSM modem (1-port) converter detected
[4756543.963290] usb 1-9.5.2: GSM modem (1-port) converter now attached to ttyUSB0
[4756543.963354] option 1-9.5.2:1.2: GSM modem (1-port) converter detected
[4756543.963425] usb 1-9.5.2: GSM modem (1-port) converter now attached to ttyUSB1
[4756543.963492] option 1-9.5.2:1.3: GSM modem (1-port) converter detected
[4756543.963571] usb 1-9.5.2: GSM modem (1-port) converter now attached to ttyUSB2
[4756543.969308] qmi_wwan 1-9.5.2:1.8: cdc-wdm2: USB WDM device
[4756543.969471] qmi_wwan 1-9.5.2:1.8 wwan0: register ‘qmi_wwan’ at usb-0000:00:14.0-9.5.2, WWAN/QMI device, 06:16:6d:3d:92:5e
[4756543.975224] cdc_ether: probe of 1-9.5.2:1.19 failed with error -22
[4756543.987348] qmi_wwan 1-9.5.2:1.8 wwx06166d3d925e: renamed from wwan0


#2

I haven’t seen this issue, but I haven’t had much of a chance to work with the wp76 yet. I see that you have posted to the WP forum as well and haven’t gotten a response there. I will talk to some people to try to get an answer for you.


#3

OK thanks David, appreciate your help/


#4

Was there any resolution here to this? I’m getting the same issue on Ubuntu 14.04


#5

Hi here,

this is a known WP76 problem affecting Linux hosts with >= 4.4 kernels (typically Ubuntu 16.04, among others…)
Windows hosts (including VM on top of Windows hosts) are not affected.
A fix has been found and integrated for the next WP76 Release, coming within the end of the year.

Unfortunately, there is no workaround concerning USB.
An alternative solution is to use Ethernet. You’ll need to connect to the serial terminal first to:

  • get the Ethernet IP address (ifconfig)
  • take down the firewall (iptables -F && iptables -A INPUT -j ACCEPT && iptables -A FORWARD -j ACCEPT) otherwise you won’t be able to connect through SSH over Ethernet

Note that these steps will have to be done after each device boot.


#6

I posted the solution here: https://forum.sierrawireless.com/viewtopic.php?f=178&t=10703&sid=255e962cf1ec4176ce7f497e17f314c0

It’s not very user friendly though since it involves patching your kernel for your wp76. Alternatively you just need to wait until the next official release of the wp76 firmware comes out.


#7

Hi @daav and @dfrey,

First of all thank you for your support. I’m wondering if the same problem happens on WP77 modules because the same error as in the original post happens to me.

And regarding the Ethernet workaround, do you mean that we need to shut down the firewall on the target device? If so, how on earth can we log onto the device with no usb connection? Change to another windows laptop first then swap back every time I reboot the device?


#8

Hi @lyao

Yes, WP77 is probably impacted as well.

And yes, the firewall needs to be shutdown on the target device.
You can do it by connecting to the RS232 port of the board (e.g. with an USB-Serial converter), and open a serial terminal (speed: 115200): you will get a simple terminal that let you entering the commands above.


#9

Thanks a lot daav. Now I have been able to log onto the device via serial port. I entered the commands but still no Ethernet connection displayed on my laptop. On the laptop it can be detected that a wire is attached but I cannot connect to the network.

On the target there are 5 network interfaces which are bridge0, ecm0, eth0, lo and rmnet0. Is it true that the serial port is only used for ssh login rather than application update and etc.?


#10

Please note that when using Ethernet, the device will need to have an IP address allocated by a DHCP server. So it typically means that direct Ethernet connection between your laptop and the device won’t work unless our PC provides a DHCP server.

What we’re usually doing here is to connect the device to a switch, so that it can get its IP address from our LAN DHCP server.


#11

Hi @lyao,

You can try to use a Windows PC as a workaround for the issue until the next release comes out. It’s true that you can’t directly update over the serial port. You could use a USB flash drive or SD card to move the .update file to the device and then run update myfile.wp85.update to apply the update. But using Windows temporarily will be easier if that’s an option for you.


#12

I’d just like to chime in that occasionally Windows also has an issue where the device does not issue it an IP address. One workaround I’ve found by chance is that if you issue cm data connect command and wait a few seconds then the device will issue an IP to Windows. Once that happens you can use cm data connect -1 to kill the IP connection on the device and the IP address will stay for SSH access.


#13

Hi @dfrey,

Is there an update on when the firmware for WP76/77 modules are being released?

Thanks!


#14

I think I remember someone saying early January.


#15

Hi,

seems below firmware works correctly with ubuntu 14.04

https://source.sierrawireless.com/~/media/support_downloads/airprime/software/wp76xx/release6.1/wp76xx_release6.1_generic_exe.ashx?la=en