WP7504 with Legato 18.04.0


#1

Hi,

I have a mangOH Red with WP7504 with the latest firmware from Sierra Wireless.

Device: WP7504
IMEI:
FSN:
Firmware: SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
Bootloader: SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
priIdPn: 9905087
priIdRev: 01.09
skuId: 1102710

I’m wondering if it is possible to use Legato version 18.04.0 with this? Officially the documentation supports 16.10.4, which is what I’ve been using until now. When I upgrade to 18.04 I’m able to perform an update on the device but it reboots multiple times and goes back to 16.10.4.


#2

It should work fine.

Did you follow the getting started guide?


#3

Yes, I did. The problem is that the device resets multiple times after I update from 16.10 to 18.04 and then somehow goes back to 16.10. Is there a built-in rollback mechanism that I’m not aware of?


#4

How are you powering the device?
can you run
cm radio

I wonder if you are jumping to a 2G network and if your computer doesnt have enough juice to power the device.


#5

Powered through USB.

Power: ON
Current Network Operator: T-Mobile
RAT: UMTS network (LE_MRC_RAT_UMTS)
Status: Registered to a roaming network (LE_MRC_REG_ROAMING)
Signal: Very weak signal strength (1)

Is there another way I can power the device?


#6

signal strengh looks week too.
Yes, you can power through a USB wall adapter. Just power through the console USB. Adjust by looking at step 3.3.4 on Getting Started guide.


#7

So I used a 5V USB wall adapter to power the board through the console USB, but even though the PWR Led is on I can’t connect to it through the CF3 USB. I’m afraid the board is damaged?

I’m using a second mangOH Red board now. I updated the firmware and Legato. After updating Legato I noticed this in the console log. I don’t know if it’s relevant but it could point to something

[ 194.952479] 0_bq24296: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ’
insmod: can’t insert ‘/legato/systems/current/modules/0-bq24296.ko’: invalid module format
[ 194.979276] 0_cp2130: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ‘’
insmod: can’t insert ‘/legato/systems/current/modules/0-cp2130.ko’: invalid module format
[ 195.009339] 0_iio: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ’ sh’
insmod: can’t insert ‘/legato/systems/current/modules/0-iio.ko’: invalid module format
[ 195.035312] 0_led: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ’ sh’
insmod: can’t insert ‘/legato/systems/current/modules/0-led.ko’: invalid module format
[ 195.060796] 0_ltc294x: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ’
insmod: can’t insert ‘/legato/systems/current/modules/0-ltc294x.ko’: invalid module format
[ 195.086555] 1_iio_kfifo_buf: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ’
insmod: can’t insert ‘/legato/systems/current/modules/1-iio-kfifo-buf.ko’: invalid module format
[ 195.113077] 2_bmp280: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ‘’
insmod: can’t insert ‘/legato/systems/current/modules/2-bmp280.ko’: invalid module format
[ 195.138592] 2_iio_triggered_buffer: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_’
insmod: can’t insert ‘/legato/systems/current/modules/2-iio-triggered-buffer.ko’: invalid module fort
[ 195.165389] 3_bmi160: version magic '3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ‘’
insmod: can’t insert ‘/legato/systems/current/modules/3-bmi160.ko’: invalid module format
[ 195.190996] 3_bmp280_i2c: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARM’
insmod: can’t insert ‘/legato/systems/current/modules/3-bmp280-i2c.ko’: invalid module format
[ 195.216664] 4_bmi160_i2c: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARM’
insmod: can’t insert ‘/legato/systems/current/modules/4-bmi160-i2c.ko’: invalid module format
[ 195.244132] 9_mangoh_red_dv5: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload’
insmod: can’t insert ‘/legato/systems/current/modules/9-mangoh_red_dv5.ko’: invalid module format
[ 195.270471] spisvc: version magic ‘3.14.29ltsi-961ca71325_ab5094eade preempt mod_unload ARMv7 ’ s’
insmod: can’t insert ‘/legato/systems/current/modules/spisvc.ko’: invalid module format
[ 197.510819] softdog: Software Watchdog Timer: 0.08 initialized. soft_noboot=0 soft_margin=60 sec )

It then reboots multiple times and goes down to 16.10.

Appreciate your help with this.


#8

It looks like your toolchain doesn’t match the linux version that’s on your target.


#9

Are you using a VM?

can you run
make clean
make red_wp750x


#10

Thanks @dfrey, I was using an older toolchain that was installed on my computer. Switching to the new one fixed the problem.

@asyal, I’m using a native Ubuntu 16.04. dfrey’s observsation helped me fixed the issue. Thanks for the help.