WiFi connectivity on MangOH Yellow

I trying to connect to WiFi using on-board WiFi adapter of MangOH Yellow (v0.5.0) and it seems ok
but no pings works:
root@swi-mdm9x28-wp:~# wifi client connect 0xa9f
CONNECTED: interface: wlan0, bssid: 78:24:af:97:ae:70
root@swi-mdm9x28-wp:~# ping 2001:4860:4860::8888
PING 2001:4860:4860::8888 (2001:4860:4860::8888): 56 data bytes
ping: sendto: Network is unreachable

wlan0 Link encap:Ethernet HWaddr 3C:E1:A1:E8:AA:4A

  •      inet6 addr: fe80::3ee1:a1ff:fee8:aa4a/64 Scope:Link*
  •      RX packets:20611 errors:0 dropped:9 overruns:0* 

questions are:
1). it is seems that it is only IPv6 supported?
2). I tried to activate IPv6 on router (ASUS RT-N66U) but do not see MangOH board in list of connected deviced to WiFi. How to check WiFi connection status on board?
wifi client status’ would be usedful command
3) How to get it working ?!
in dmesg output all seems ok as well

[ 84.436037] sdhci_msm 7864900.sdhci: card claims to support voltages below defined range
[ 84.451122] mmc0: queuing unknown CIS tuple 0x91 (3 bytes)
[ 84.453030] mmc0: new high speed SDIO card at address 0001
[ 84.852677] wlcore: wl18xx HW: 183x or 180x, PG 2.2 (ROM 0x11)
[ 84.866763] wlcore: loaded
[ 86.253204] wlcore: PHY firmware version: Rev
[ 86.304863] wlcore: firmware booted (Rev
[ 86.332112] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 121.441055] sierra_startup_monitor
[ 155.327718] wlan0: authenticate with c8:e7:d8:9e:d1:b6
[ 155.344530] wlan0: send auth to c8:e7:d8:9e:d1:b6 (try 1/3)
[ 155.361975] wlan0: authenticated
[ 155.370417] wlan0: associate with c8:e7:d8:9e:d1:b6 (try 1/3)
[ 155.375064] wlan0: RX AssocResp from c8:e7:d8:9e:d1:b6 (capab=0x411 status=0 aid=1)
[ 155.384410] wlan0: associated
[ 155.384458] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 155.616291] wlcore: Association completed.

@Zahid can you comment?

Btw, wlcore is the TI Wifi driver’s loadable core module. Do have the TI Wifi IoT card plugged in. Then you would get those messages. The TI is not the on-board wifi for yellow, the Cypress is, and you cannot run both them for 2 Wifi interfaces currently - Legato, does not support multiple Wifi interfaces also. The other possibility is that you have made changes to the root filesystem such that TI is the default interface in /etc/network/interfaces, i.e. /etc/init.d/tiwifi. Also, if the interfaces file has been nuked by default Legato will try starting the TI wlan. Let us know if either of these are issues.


I have fixed it by command:
/sbin/udhcpc -R -b -i wlan0