WiFi Client Scan & Connect - Error


#1

I am attempting to connect to a WiFi access point but I have been having issues. The first time I was able to set the security and the passphrase but could not connect. I would consistently get an error or -6.

root@swi-mdm9x15:~# wifi client connect 0x10000001
ERROR: le_wifiClient_Connect returns error code -6
root@swi-mdm9x15:~#

I moved to another access point as I thought the issue might be the passphrase had spaces in it. With the spaces I was not sure how to set up teh pass phrase, do you need quotes or not and will it eve work if there are spaces. I tried with and without quotes but still got the -6 error.

When attempting on the second access point all I got when attempting a scan was:

root@swi-mdm9x15:~# wifi client scan
starting scan
DEBUG: le_wifiClient_GetFirstAccessPoint ERRORroot@swi-mdm9x15:~#

If there are any suggestions as to what I may have changed or done incorrectly I would appreciate the help.

Thankfully
Kas


#2

Hi Kas,

I tried the same commands and didnt run into any issues. Could you show your logread -f traces?

regards,
ashish


#3

Hello @asyal,

I have attached my logread -f file and changed my password for security reasons but the overall form remains the same (The XXXXXX YYYYYY 123 PPPP). I hope this provides the information needed.

Thanks
Kas

Ps. where would I be able to find what the error codes mean.

logread_-f.txt (31.4 KB)


#4

Hello @asyal,

Is there any further information regarding how I could resolve this issue or what the error means.

Thanks
Kas


#5

Hi Kas,
@Kas.Lewis

I finally got some time to try this out.

The issue you saw might be due to the firmware version you might have on the module.
I was getting the same error as you but then I downloaded the latest firmware from:
http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

The commands worked as what was written in the doc on the network (note I changed the password I used)

wifi client start
wifi client scan
wifi client setsecurityproto 0x10000001 3
wifi client setpassphrase 0x10000001 password
wifi client connect 0x10000001

cheers,
Ashish


#6

Hello @asyal,

Thank you for the response. I have updated my firmware to the most recent but I am still having issues. I have only tried it at one location. I will attempt a different router and internet provider tomorrow. The error is below in the screenshot.

I will update as to m findings tomorrow but if you have any information as to what may be causing the current issue that would be great.

Thankfully
Kas


#7

why does your legato version showed modified?
Here is what i see when i redownload the firmware:
root@swi-mdm9x15:~# cm info
Device: WP8548
IMEI: 359377060016051
FSN: LL604200070705
Firmware: SWI9X15Y_07.11.11.00 r33161 CARMD-EV-FRMWR1 2016/09/20 16:36:44
Bootloader: SWI9X15Y_07.11.11.00 r33161 CARMD-EV-FRMWR1 2016/09/20 16:36:44
root@swi-mdm9x15:~# legato version
16.07.0_5aabbe8a5c30c0b16469b0ea885a82f6
root@swi-mdm9x15:~# wifi client start
successfully called start
root@swi-mdm9x15:~# wifi client scan
No issues after this…


#8

Hello @asyal,

The only modifications made were those listed in the blog I wrote on setting up the Legato environment. There should be nothing else. I did a repo sync as well to be sure everything was up to date and then rebuilt Legato before installing it again on the mangOH board after doing a fresh firmware update. Is there away to ensure a fresh Legato framework is installed with out creating a fresh new VM.

Thanks
Kas


#9

can you do a firmware install only? Dont use the VM to download the mangoh/legato apps.
Basically, do firmware install for WP module from source
http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

Dont install any app from the VM and run the commands above.


#10

Without running

cd mangOH/legato
make wp85
instlegato wp85 192.168.2.2

I can not ssh into the mangoh board. I just get a connection timed out error.

Kas


#11

After reinstalling legato on the mangOH board it appears as though I can not SSH into teh board at all.

Kas


#12

why did you have re-install legato?
Just redownload the firmware from the source site I sent to you.
What do you see?


#13

I tried that and I could not SSH into the mangOH board. I then attempted to run the instlegato command but that to says “Device address 192.168.2.2 seems to be unreachable”. I have also attempted to ping the mangOH board, this to gives 100% packet loss, “Destination host unreachable”.

I can not get access to the board for some reason. I have attempted to reseat the module, power cycled teh board numerous times. Nothing is showing signs of working.

Kas


#14

Can you pull pin 7 on SW401 up and try to redowload the firmware?
If this doesnt work, you might need to use fwupdate tool in linux.


#15

I have attempted to flash the firmware with SW 7 in the on position and then power cycle the board. Both before and after cycling the board I was unable to ping the board.

I also moved SW back to off and I still cannot ping the board. Any access via 192.168.2.2 does not appear to work.

Kas


#16

Is there anything else to try at this point or is the board somehow bricked/dead ? The board has been either on the same table the whole time or in the anti-static bag it comes in. Any information on how to possibly proceed with this board would be helpful.

Thanks
Kas

Still cant connect to the board via SSH even with a successful firmware update :frowning:


#17

I have asked internally…There is a way to not have this error if you use a linux machine.
Need to check on windows. will get back to you


#18

Hi Kas,

Have you tried connecting to the RS232 Console Port (UART 2) on mangOH? This way you can monitor the the Linux/Legato boot process - you might get some clues as to what’s happening from here.

I once had an issue where I couldn’t SSH into the modem after incorrectly editing a file on the WP8548 which prevented it from starting a few important services, including SSH. As a result, I couldn’t SSH into it nor did I know what was going on until I monitored the boot process on the Console port. I was able to log in via the Console port, edit the file (correctly this time) then reboot to restore it.

Just a thought.

Cheers,
Raf


#19

Hi Kas,

As suggested by Raf, could you share the kernel log message on the RS232 port?
This will give us an idea what went wrong with your unit.

regards,
Ashish


#20

1 (ARMv7), cr=10c5387d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instructio n cache
[ 0.000000] Machine model: QCT MSM9615 CDP
[ 0.000000] memory pool 3 (start 4ff00000 size 100000) initialized
[ 0.000000] Memory policy: Data cache writeback
[ 0.000000] L310 cache controller enabled
[ 0.000000] l2x0: 8 ways, CACHE_ID 0x410000c8, AUX_CTRL 0x00540000, Cache siz e: 262144 B
[ 0.000000] socinfo_init: v7, id=106, ver=3.0, raw_id=1760, raw_ver=1760, hw_ plat=0, hw_plat_ver=65536
[ 0.000000] accessory_chip=0, hw_plat_subtype=0, pmic_model=19, pmic_die_rev ision=3
[ 0.000000] CPU: All CPU(s) started in SVC mode.
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pag es: 40720
[ 0.000000] Kernel command line: console=ttyHSL0,115200 console=ttyHSL1,1152 00 fudge_ro_rootfs=true rootfs_ro=true mtdparts=msm_nand:0x00100000@0x051c0000(b ootloader),0x01400000(kernel),0x03140000(rootfs),0x02780000(user0),0x08b80000(us er1),0x00500000(user2),0x00200000(user3) androidboot.serialno=MDM9615 lkversion= 1.3.0_a50272dbb2 androidboot.baseband=msm
[ 0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] allocated 507904 bytes of page_cgroup
[ 0.000000] please try ‘cgroup_disable=memory’ option if you don’t want memor y cgroups
[ 0.000000] Memory: 150472K/164864K available (6762K kernel code, 631K rwdata , 2256K rodata, 1366K init, 1265K bss, 14392K reserved, 0K highmem)
[ 0.000000] Virtual kernel memory layout:
[ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
[ 0.000000] vmalloc : 0xd0000000 - 0xff000000 ( 752 MB)
[ 0.000000] lowmem : 0xc0000000 - 0xcf800000 ( 248 MB)
[ 0.000000] pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
[ 0.000000] modules : 0xbf000000 - 0xbfe00000 ( 14 MB)
[ 0.000000] .text : 0xc0008000 - 0xc08d69e0 (9019 kB)
[ 0.000000] .init : 0xc08d7000 - 0xc0a2cb6c (1367 kB)
[ 0.000000] .data : 0xc0a2e000 - 0xc0acbf7c ( 632 kB)
[ 0.000000] .bss : 0xc0acbf7c - 0xc0c084bc (1266 kB)
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] Preemptible hierarchical RCU implementation.
[ 0.000000] NR_IRQS:681
[ 0.000030] sched_clock: 32 bits at 32kHz, resolution 30520ns, wraps every 65 542000541696ns
[ 0.000610] Console: colour dummy device 80x30
[ 0.000701] Calibrating delay loop… 366.18 BogoMIPS (lpj=1830912)
[ 0.060491] pid_max: default: 32768 minimum: 301
[ 0.060949] Security Framework initialized
[ 0.061040] Smack: Initializing.
[ 0.061468] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.061498] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.063268] Initializing cgroup subsys debug
[ 0.063299] Initializing cgroup subsys memory
[ 0.063360] Initializing cgroup subsys devices
[ 0.063390] Initializing cgroup subsys freezer
[ 0.063390] Initializing cgroup subsys net_cls
[ 0.063421] Initializing cgroup subsys blkio
[ 0.063482] CPU: Testing write buffer coherency: ok
[ 0.063604] ftrace: allocating 22813 entries in 67 pages
[ 0.145429] Setting up static identity map for 0x40e1e180 - 0x40e1e1d8
[ 0.169327] devtmpfs: initialized
[ 0.178818] VFP support v0.3: implementor 41 architecture 2 part 30 variant 5 rev 1
[ 0.181474] regulator-dummy: no parameters
[ 0.182054] NET: Registered protocol family 16
[ 0.183244] DMA: preallocated 256 KiB pool for atomic coherent allocations
[ 0.183488] AXI: msm_bus_fabric_init_driver(): msm_bus_fabric_init_driver
[ 0.185045] msm_serial_hsl_init: driver initialized
[ 0.185808] cpuidle: using governor ladder
[ 0.185838] cpuidle: using governor menu
[ 0.186571] msm_rpm_init: RPM firmware 3.0.16842958
[ 0.186815] gpio_cf3_low_power_reset_toggle: Setting up LowPower_RESET pin to ggle timer
[ 0.186845] unmatched machine ID in register_i2c_devices
[ 0.186876] wl18xx board initialization done
[ 0.187395] 8018_s1: 500 <–> 1150 mV at 1150 mV normal idle
[ 0.187822] 8018_s2: 1225 <–> 1300 mV at 1300 mV normal idle
[ 0.188707] 8018_s3: 1800 mV normal idle
[ 0.189226] 8018_s4: 2100 <–> 2200 mV at 2200 mV normal idle
[ 0.190050] 8018_s5: 1350 mV normal idle
[ 0.190965] 8018_l2: 1800 mV normal idle
[ 0.191851] 8018_l3: 1800 mV normal idle
[ 0.192278] 8018_l4: 3300 mV normal idle
[ 0.192675] 8018_l5: 2850 mV normal idle
[ 0.193041] 8018_l6: 1800 <–> 2850 mV at 2850 mV normal idle
[ 0.193468] 8018_l7: 1850 <–> 1900 mV at 1900 mV normal idle
[ 0.193560] 8018_l7: supplied by 8018_s4
[ 0.193926] 8018_l8: 1200 mV normal idle
[ 0.194048] 8018_l8: supplied by 8018_s3
[ 0.194414] 8018_l9: 750 <–> 1150 mV at 1150 mV normal idle
[ 0.194506] 8018_l9: supplied by 8018_s5
[ 0.194903] 8018_l10: 1050 mV normal idle
[ 0.194994] 8018_l10: supplied by 8018_s5
[ 0.195452] 8018_l11: 1050 mV normal idle
[ 0.195544] 8018_l11: supplied by 8018_s5
[ 0.195971] 8018_l12: 1050 mV normal idle
[ 0.196062] 8018_l12: supplied by 8018_s5
[ 0.196490] 8018_l13: 1850 <–> 2950 mV at 2950 mV normal idle
[ 0.196886] 8018_l14: 2850 mV normal idle
[ 0.197253] 8018_lvs1: no parameters
[ 0.197344] 8018_lvs1: supplied by 8018_s3
[ 0.197741] vdd_dig_corner: 0 <–> 0 mV at 0 mV
[ 0.205005] ext_2p95v: no parameters
[ 0.205249] gpio_vreg_probe: id=18, name=ext_2p95v, gpio=18, gpio_label=ext_2 p95_en
[ 0.205768] pm8018_probe: PMIC revision 1: F3
[ 0.205798] pm8018_probe: PMIC revision 2: 08
[ 0.205829] pm8018_probe: PMIC version: PM8018 rev 2.1
[ 0.205829] pm8018_probe: PMIC Restart Reason: Triggered from KPD (power key press)
[ 0.207324] pm_gpio_probe: OK: base=88, ngpio=6
[ 0.207874] pm8xxx_mpp_probe: OK: base=94, ngpio=6
[ 0.209980] msm_serial_hsl_probe: ttyHSL0 is disabled.
[ 0.210041] msm_serial_hsl: probe of msm_serial_hsl.0 failed with error -1
[ 0.210499] msm_serial_hsl_probe: ttyHSL1 is reserved for CONSOLE service.
[ 0.210499] msm_serial_hsl_probe: detected port #1 (ttyHSL1)
[ 0.210773] msm_serial_hsl.1: ttyHSL1 at MMIO 0x16440000 (irq = 186, base_bau d = 460800) is a MSM
[ 0.210895] msm_hsl_console_setup: console setup on port #1
[ 0.315122] gpio_cf3_low_power_reset_timer_callback: LowPower_RESET pin toggl ed high
[ 0.315153] gpio_cf3_low_power_reset_timer_callback: LowPower_RESET pin toggl e timer deleted
[ 0.840805] console [ttyHSL1] enabled
[ 0.856218] cpufreq_table_init: CPU: 4 scaling frequencies supported.
[ 0.862200] hw-breakpoint: Debug register access (0xee003e17) caused undefine d instruction on CPU 0
[ 0.870654] hw-breakpoint: CPU 0 failed to disable vector catch
[ 0.877216] socinfo_init_dev: device_register fail (-22)
[ 0.884480] sps:REVISION of BAM 0xd0060000 is 0x5.
[ 0.888448] sps:BAM 0x12244000 is registered.
[ 0.892781] sps:sps is ready.[ 1.187273] NET: Registered protocol family 2
[ 1.192614] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[ 1.198596] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[ 1.205005] TCP: Hash tables configured (established 2048 bind 2048)
[ 1.211353] TCP: reno registered
[ 1.214466] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 1.220326] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
vice ac
[ 2.020204] Setting mtd->writebufsize to 0x800
[ 2.024629] Found a supported NAND device
[ 2.028567] NAND Controller ID : 0x4030
[ 2.032443] NAND Device ID : 0x1590ac2c
[ 2.036288] Buswidth : 8 Bits
[ 2.039249] Density : 512 MByte
[ 2.042484] Pagesize : 2048 Bytes
[ 2.045780] Erasesize: 131072 Bytes
[ 2.049229] Oobsize : 64 Bytes
[ 2.052372] CFG0 Init : 0xa8d408c0
[ 2.055821] CFG1 Init : 0x0004745c
[ 2.059301] ECCBUFCFG : 0x00000203
[ 2.062810] CW size : 528 bytes
[ 2.066168] BCH ECC : disabled
[ 2.069525] 7 cmdlinepart partitions found on MTD device msm_nand
[ 2.075568] Creating 7 MTD partitions on “msm_nand”:
[ 2.080512] 0x0000051c0000-0x0000052c0000 : “bootloader”
[ 2.088936] 0x0000052c0000-0x0000066c0000 : “kernel”
[ 2.110361] 0x0000066c0000-0x000009800000 : "rootfs"
registered new interface driver dm9601
[ 2.382206] usbcore: registered new interface driver smsc75xx
[ 2.387883] usbcore: registered new interface driver smsc95xx
[ 2.393590] usbcore: registered new interface driver net1080
[ 2.399206] usbcore: registered new interface driver cdc_subset
[ 2.405127] usbcore: registered new interface driver zaurus
[ 2.410743] usbcore: registered new interface driver MOSCHIP usb-ethernet dri ver
[ 2.418068] usbcore: registered new interface driver int51x1
[ 2.423775] usbcore: registered new interface driver cdc_ncm
[ 2.429238] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 2.449656] msm_hsusb_host msm_hsusb_host: unable to find transceiver
[ 2.468426] platform msm_hsusb_host: Driver msm_hsusb_host requests probe def erral
[ 2.488295] msm_hsic_host msm_hsic_host: Qualcomm EHCI Host Controller using HSIC
[ 2.494948] msm_hsic_host msm_hsic_host: new USB bus registered, assigned bus number 1
[ 2.529986] msm_hsic_host msm_hsic_host: irq 264, io mem 0x12540000
[ 2.549916] msm_hsic_host msm_hsic_host: USB 2.0 started, EHCI 1.00
[ 2.557515] hub 1-0:1.0: USB hub found
[ 2.560445] hub 1-0:1.0: 1 port detected
[ 2.566183] usbcore: registered new interface driver cdc_acm
[ 2.570944] cdc_acm: USB Abstract Control Model driver for USB modems and ISD N adapters
[ 2.579124] usbcore: registered new interface driver usbserial
[ 2.584831] usbcore: registered new interface driver ftdi_sio
[ 2.590477] usbserial: USB Serial support registered for FTDI USB Serial Devi ce
[ 2.597894] usbcore: registered new interface driver option
[ 2.603326] usbserial: USB Serial support registered for GSM modem (1-port)
[ 2.610437] usbcore: registered new interface driver qcserial
[ 2.615992] usbserial: USB Serial support registered for Qualcomm USB modem
[ 2.622981] usbcore: registered new interface driver sierra
[ 2.628444] usbserial: USB Serial support registered for Sierra USB modem
[ 2.635281] usbcore: registered new interface driver GobiSerial
[ 2.641171] usbserial: USB Serial support registered for GobiSerial
[ 2.647428] usbcore: registered new interface driver usb_ehset_test
[ 2.653685] msm_otg msm_otg: msm_otg probe
[ 2.657652] msm_otg msm_otg: failed to get phy_clk
[ 2.662810] msm_otg msm_otg: OTG regs = d006e000
[ 2.669800] misc usb_link: registered misc device minor 47
[ 2.678406] mbim_init: initialize 1 instances
[ 2.682252] mbim_init: Initialized 1 ports
[ 2.691377] rndis_qc_init: initialize rndis QC instance
[ 2.697054] android_usb gadget: android_usb ready
[ 2.702273] input: pmic8xxx_pwrkey as /devices/platform/msm_ssbi.0/pm8018-cor e/pm8xxx-pwrkey/input/input0
[ 2.713383] rtc-pm8xxx rtc-pm8xxx: rtc core: registered pm8xxx_rtc as rtc0
[ 2.719578] i2c /dev entries driver
[ 2.724309] pm8xxx-adc supply pa_therm not found, using dummy regulator
[ 2.730444] swimcu_hwmon_probe: start
[ 2.733862] swimcu_hwmon_probe: success num 2
[ 2.762368] pm8xxx_tm_probe: OK
[ 2.765298] usbcore: registered new interface driver usbhid
[ 2.770120] usbhid: USB HID core driver
[ 2.775339] usbcore: registered new interface driver snd-usb-audio
[ 2.782664] voice_allocate_shared_memory: ION memory allocation failed
[ 2.788585] msm_pcm_probe: dev name msm-voip-dsp
[ 2.793407] msm_pcm_probe: dev name msm-host-pcm-voice
[ 2.799175] msm_pcm_probe: dev name msm-pcm-dsp
[ 2.803021] msm_pcm_probe: dev name msm-multi-ch-pcm-dsp
[ 2.809613] mdm9615_audio_init(): Interface Type (wm8944) = 1
[ 2.815931] mdm9615_audio_init - AR8, AR755xRD and CF3 configuration
[ 2.821669] soc-audio soc-audio.0: ASoC: machine mdm9615-wm8944-snd-card shou ld use snd_soc_register_card()
[ 2.850541] soc-audio soc-audio.0: snd-soc-dummy-dai <-> MultiMedia1 mapping ok
[ 2.857286] soc-audio soc-audio.0: snd-soc-dummy-dai <-> MultiMedia2 mapping ok
[ 2.864581] soc-audio soc-audio.0: snd-soc-dummy-dai <-> CS-VOICE mapping ok
[ 2.871814] soc-audio soc-audio.0: snd-soc-dummy-dai <-> VoIP mapping ok
[ 2.878132] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-q6.241 mapping ok
[ 2.885243] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-q6.240 mapping ok
[ 2.892354] soc-audio soc-audio.0: snd-soc-dummy-dai <-> SLIMBUS0_HOSTLESS ma pping ok
[ 2.900137] soc-audio soc-audio.0: snd-soc-dummy-dai <-> AUXPCM_HOSTLESS mapp ing ok
[ 2.907767] soc-audio soc-audio.0: snd-soc-dummy-dai <-> VoLTE mapping ok
[ 2.914603] soc-audio soc-audio.0: snd-soc-dummy-dai <-> DTMF_RX_HOSTLESS map ping ok
[ 2.922173] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-stub mapping ok
[ 2.929009] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-stub mapping ok
[ 2.935785] usb 1-1: new high-speed USB device number 2 using msm_hsic_host
[ 2.942896] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-stub mapping ok
[ 2.949671] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-stub mapping ok
[ 2.956844] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-stub mapping ok
[ 2.963375] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-q6.224 mapping ok
[ 2.970364] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-q6.225 mapping ok
[ 2.977353] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-q6.32773 mapping o k
[ 2.984800] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-q6.32772 mapping o k
[ 2.992064] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-q6.32771 mapping o k
[ 3.000457] hub 1-1:1.0: USB hub found
[ 3.003418] soc-audio soc-audio.0: msm-stub-rx <-> msm-dai-q6.2 mapping ok
[ 3.010102] hub 1-1:1.0: 3 ports detected
[ 3.014771] soc-audio soc-audio.0: msm-stub-tx <-> msm-dai-q6.3 mapping ok
[ 3.023805] soc-audio soc-audio.0: wm8944-hifi <-> msm-dai-q6.0 mapping ok
[ 3.029879] soc-audio soc-audio.0: wm8944-hifi <-> msm-dai-q6.1 mapping ok
[ 3.052067] TCP: cubic registered
[ 3.054417] NET: Registered protocol family 17
[ 3.059484] Registering SWP/SWPB emulation handler
[ 3.070715] clock_late_init() disabled 39 unused clocks
[ 3.077430] sps:BAM 0x124c2000 is registered.
[ 3.086525] no pmic restart interrupt specified
[ 3.090401] MSM Watchdog Initialized
[ 3.097329] ext_2p95v: disabling
[ 3.099649] regulator-dummy: disabling
[ 3.117259] msm_otg msm_otg: phy_reset: success
[ 3.121959] rtc-pm8xxx rtc-pm8xxx: setting system clock to 1970-01-01 00:02:0 9 UTC (129)
[ 3.133557] ### dt-test ### No testcase data in device tree; not running test s
[ 3.146253] ALSA device list:
[ 3.150373] #0: mdm9615-wm8944-snd-card
[ 3.165359] Freeing unused kernel memory: 1364K (c08d7000 - c0a2c000)
[ 3.710178] usb 1-1.3: new high-speed USB device number 4 using msm_hsic_host
[ 3.742347] hub 1-1.3:1.0: USB hub found
[ 3.745643] hub 1-1.3:1.0: 5 ports detected
[ 3.753090] ubi0: scanning is finished
[ 3.764504] ubi0 warning: print_rsvd_warning: cannot reserve enough PEBs for bad PEB handling, reserved 58, need 80
[ 3.776072] ubi0: attached mtd2 (name “rootfs”, size 49 MiB)
[ 3.780772] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[ 3.787578] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[ 3.794353] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[ 3.801281] ubi0: good PEBs: 394, bad PEBs: 0, corrupted PEBs: 0
[ 3.807263] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 12 8
[ 3.814497] ubi0: max/mean erase counter: 1/0, WL threshold: 4096, image sequ ence number: 2264427
[ 3.823409] ubi0: available PEBs: 0, total reserved PEBs: 394, PEBs reserved for bad PEB handling: 58
[ 3.832565] ubi0: background thread “ubi_bgt0d” started, PID 77
UBI device number 0, total 394 LEBs (50028544 bytes, 47.7 MiB), available 0 LEBs (0 bytes), LEB size 126976 bytes (124.0 KiB)
[ 3.871204] block ubiblock0_0: created from ubi0:0(rootfs)
rootfs: dev ‘/dev/ubiblock0_0’ 'squashfs’
S02mount_early: Executing mount_early_user_start…
S02mount_early: Trying to mount UBIFS on /mnt/flash using [usrquota,grpquota,rw] mount options…
[ 6.595879] ubi2: scanning is finished
[ 6.598718] ubi2 error: ubi_read_volume_table: the layout volume was not foun d
[ 6.606683] ubi2 error: ubi_attach_mtd_dev: failed to attach mtd4, error -22
ubiattach: error!: cannot attach mtd4
error 22 (Invalid argument)
S02mount_early: Unable to attach mtd partition user1 to UBI logical device 2
S02mount_early: Trying to mount UBIFS on /mnt/flash using [rw] mount options…
SSS▒▒S▒▒▒2 error: ubi_attach_mtd_dev: failed to attach mtd4, error -22
ubiattach: error!: cannot attach mtd4
error 22 (Invalid argument)
PuTTYS02mount_early: Unable to attach mtd partition user1 to UBI logical device 2
[ 8.028597] ubi1: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[ 8.039737] ubi1: VID header offset: 2048 (aligned 2048), data offset: 4096
[ 8.045811] ubi1: good PEBs: 316, bad PEBs: 0, corrupted PEBs: 0
[ 8.051915] ubi1: user volume: 1, internal volumes: 1, max. volumes count: 12 8
[ 8.058873] ubi1: max/mean erase counter: 1/0, WL threshold: 4096, image sequ ence number: 292670867
[ 8.067968] ubi1: available PEBs: 0, total reserved PEBs: 316, PEBs reserved for bad PEB handling: 80
[ 8.077155] ubi1: background thread “ubi_bgt1d” started, PID 178
UBI device number 1, total 316 LEBs (40124416 bytes, 38.3 MiB), available 0 LEBs (0 bytes), LEB size 126976 bytes (124.0 KiB)
[ 8.121562] block ubiblock1_0: created from ubi1:0(legato)
sd_mod [ 8.961330] usbcore: registered new interface driver usb-storage
msm_sdcc ▒▒▒: RmNet(1) dual Speed, IN:ep10in OUT:ep7out
[ 10.066564] apr_tal: SMD_EVENT_OPEN
[ 10.069403] Match for Function Name: audio, Int #16
[ 10.074042] Match for Function Name: audio, Int #17
[ 10.078773] Match for Function Name: audio, Int #18
[ 10.083931] ecm_native_function_bind_config: ecm_native_function_bind_config MAC: 00:00:00:00:00:00
[ 10.092904] android_usb gadget: using random self ethernet address
[ 10.110849] usb0: MAC 2e:50:5b:e9:8a:20
[ 10.113688] usb0: HOST MAC 9a:93:aa:54:b1:12
[ 10.117961] Match for Function Name: cdc_ethernet, Int #19
[ 10.150038] Match for Function Name: cdc_ethernet, Int #20
[ 10.157637] msm_otg msm_otg: Avail curr from USB = 2
[ 10.161635] ci_hdrc ci_hdrc.0: CI_HDRC_CONTROLLER_SUSPEND_EVENT received
Starting syslogd/klogd: Starting diagrebootapp: [ 11.274500] nmea: smd opened
Sending discover…
Starting qmuxd: Starting mbimd: Starting tcf-agent: run_getty.sh: UART2 (=/dev/t tyHSL0) reserved for CONSOLE
[ 28.824538] PM: Syncing filesystems … noirq resume of devices complete afte r 1.281 msecs
[ 28.954402] PM: early resume of devices complete after 1.587 msecs
[ 28.955653] msm_hsic_host msm_hsic_host: HSIC-USB exited from low power mode
[ 28.994414] PM: resume of devices complete after 39.981 msecs
[ 29.075507] Restarting tasks …
[ 29.085457] mbim_read: Requests list is empty. Wait.
[ 29.112498] done.