VSCode - Legato/System: New resulted in an error

Struggling to get VSCode working:

Does it work in linux environment

I don’t have a linux environment to try it. The whole point of the article:

is that it should work on Win10

Suggest you trying with win10 vmware ubuntu, it is working fine for me

But the whole point of the article is to avoid “a cumbersome virtual machine”

@bbo claimed to have it working, and @Sarra had promised to feed back about WSL2

The topic says it is experimental…
From legato.io, it asked you to work in linux environment, you can give a try there first


Indeed - but it did say that it worked, and invited feedback.

If the “experiment” has been abandoned, that thread should be updated to say so.

not quite sure if it has been abandoned, you can wait for their update of experiment

I have tried it on Ubuntu 18.04; the command-line mangOH build succeeds, VSCode still has exactly the same problem!

  • There is no Legato ‘Create/select System’ popup, and no Legato icon;
  • Legato/System: New gives exactly the same error.



However, VSCode does now show a .adef file in the Status bar:


and, if I click on it, I get a list of .adef and .sdef files:

not sure what that tells us?


Is it still WSL???

No - this is now genuine native Ubuntu.

Still in windows 10?

No - dual-boot into native Ubuntu.

But I can now select an .sdef file - by clicking in the Status bar:

maybe that’s sufficient to be getting on with … ?

Is that actually with mangOH, or just “plain” Legato?

What would I have to do from here to try just “plain” Legato?

Would it be:

  1. Create a filesystem folder for the Workspace;
  2. “Open” it in VSCode – Ctrl+K+O;
  3. Choose an SDK; add to a new Profile.

Or does it just need the final step - Choose an SDK; add to a new Profile?

I install a legato sdk and then add it to the profile

so does it need to be a separate Profile?

You can create new profile

I can - but do I need to?

You can choose different sdk for your profile

So I added swi-wp77_5.0.1 to a new Profile:

and now I do get the Legato icon!

but still no ‘Create/select System’ popup (maybe because an .sdef is already selected?)

doing ‘Legato/System: New’ now prompts for a new system name:

So it seems that the problem was with the mangOH stuff.

Should I also add the swi-vscode-support_200624 to the new Profile?