User manual typo?


#1

I have not been able to properly set up my computer to work with legato nor make new file with file maker. Basically stuck on page 23 of the manual (ubuntu version) I did it 2 times in completely different computers yet no success, but maybe there is info that I’m missing or one typo that ruined everything i dont know. First of all looking at the video tutorial and manual they are completly different approaches (I have not tried the video method ) next in page 19 section j. the example says to use targer /opt/swi/y22-ext-SWI… yet in the sample image says /opt/swi/y-22-ext/SWI… I dont know if because I did it one way (second one) then by repeating it in same comouter the second way it all gets ruined.

When I get to make I get ERROR1 and ERROR2 no idea how to fix that some files seem to be missing all starts to fail when s=it starts using ninja it says ninja: no work to do .
I had to do it in the Virtual machine with windows to get it going because using ubuntu was just not possible


#2

@jbartol did you want to take this?


#3

Hi erickhj… you’re correct, there is a typo in the screenshot.

That is, in step 7j, when you append the version to the default name, you should use a ‘-’, not a ‘/’.

Then, in step 7k, you set your symlink as shown in the screenshot (for step k).

Assuming the Legato Distro Source version is “SWI9X07Y_02.14.04.00” (from step 7g), if you do “$ ls -al /opt/swi”, you should see the following two entries in the listing (among others):

drwxr-xr-x … y22-ext-SWI9X07Y_02.14.04.00
lrwxrwxrwx … y22-ext-wp76xx -> y22-ext-SWI9X07Y_02.14.04.00

where the second entry is the symbolic link to the first entry (the actual directory).

Then, when you get to page 22 (step 3a), you are setting the *_SYSROOT using the symbolic link. If the link wasn’t pointing to the actual directory, that would blow up the make.

(Note… when I went back to retest this, I verified my directory and symlink were correct, then did the steps to build/install mangoh distribution (section 5.1) – and my make failed similar to yours. I removed my ~/legato_framework and ~/mangOH directories, then did section 5.1 from scratch (e.g. steps 1b, 2, 3, 4) and my make worked.)