USB Audio Output


I’m trying to get a USB class audio device to work with the mangOH red platform. I’m configured the OTG usb using the commands below to enable audio.

Request: microcom -E /dev/ttyAT



Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0009010D (diag,nmea,modem,rmnet0,audio,ecm)

AT Command Source (page 78)

Once I reboot and connect the device via the USB OTG port (CF3 USB) I ran the lsusb command. The result is below.

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 08bb:2704 Texas Instruments Audio Codec
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So far it seems the device is being recognized correctly. In order to test the device I’m using one of the audio tests in the legato framework. The project I’m using is in the link below.

Once I installed the audioPlaybackRec application I execute the following command below. Despite the command running properly I don’t get any audio out of my USB device. I’ve tested this device on a Windows PC and get audio out no problem.

app runProc audioPlaybackRec --exe=audioPlaybackRecTest – PB USB /usr/share/sounds/male.wav

I’ve also tested this command using the call below and audio is successfully output on the mangOH red audio jack.

app runProc audioPlaybackRec --exe=audioPlaybackRecTest – PB MIC /usr/share/sounds/male.wav

Any guidance on how I can get external USB audio to output would be greatly appreciated.


After doing some more digging into the code for in the Legato framework it seems to me that USB audio may not yet be implemented in the code. I could be wrong but I just don’t quite see how the le_audio_OpenUsbTx function actually goes about selecting and connecting to a USB class audio device.

Could someone from Sierra possible comment on whether this functionality is currently available or maybe just a placeholder for future development?

Has anyone in the community ever had a USB audio device working?


I don’t believe USB audio is enabled but will double check tomorrow


I also have this issue. I tried to get le_audio_OpenUsbTx working.
But it did not work.