Unable to use USB to Ethernet IOT card


#1

Hi,

I had mangoH red with wp7608 and the board is mounted with ethernet IOT module . The RJ45 connectore of the IOT module is connected to local lan for testing. But I see nothing happens

Is there any applicatoin or usecase / service that I can use to explore this IOT module.

Thanking in advance.

Thanks,
Siva


#2

I think you just need to take the card out of reset. Try this:

echo 2 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio2/direction
echo 1 > /sys/class/gpio/gpio2/value

#3

Hi dfrey,

Thanks for the input. After the reset. I see led blink at RJ45 connector. However i don’t get the ip address assigned to it.

Actually we would like to access the internet from the ethernet of the mangOH board once we have a successful UE attach with the modem . Do we have any sample app to explore this use case ?

For now, I have connected the local lan to the RJ45 But no Ipaddress assigned to any of the below network interfaces. Could you please outline the interfaces below related to

root@swi-mdm9x28:~# ifconfig
bridge0 Link encap:Ethernet HWaddr 72:72:5B:EA:81:E7
inet addr:192.168.225.1 Bcast:192.168.225.255 Mask:255.255.255.0
inet6 addr: fe80::7072:5bff:fee7:7ee4%1341333244/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:76 (76.0 B)

ecm0 Link encap:Ethernet HWaddr 32:77:2B:AA:17:1B
inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::3077:2bff:feaa:171b%1341333244/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5621 errors:0 dropped:0 overruns:0 frame:0
TX packets:4238 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:294553 (287.6 KiB) TX bytes:752072 (734.4 KiB)

eth0 Link encap:Ethernet HWaddr 2E:35:F7:AE:A1:E5
inet6 addr: fe80::2c35:f7ff:feae:a1e5%1341333244/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:270 errors:0 dropped:10 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:45409 (44.3 KiB) TX bytes:712 (712.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1%1341333244/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:76 (76.0 B) TX bytes:76 (76.0 B)

rmnet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:2000 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Connect IOT Ethernet on mangho red
#4

Have you checked the wiki entries on this forum?


#5

@asyal: No, It would be great if you can point me to the wiki entries/ useful info on this topic then I would go through it in the first place.

Thanks for your support.


#6

Hi asyal,

I found some interesting use case here . Is this same wiki page are you talking about ?

Could you also please point to more documentation / video tutorials on this topic(Ethernet IOT Card)


#7

Hi
Did you restart the network service after bringing the card out of reset? worked for me.

/etc/init.d/networking restart


#8

Hi,

I had tried to configure the mangOH as cellular gateway following here.

I wanted to create a gateway between the ethernet IoT slot (eth0) and the cellular interface (rmnet_data0).
As I didnot find the eth0 interface. By mistake I have given ecm0 instead of eth0 during ./cfg_gateway.sh

Now I am not able to get the 192.168.2.2 . so I am not able to ssh to the wp7608.

Any help in reverting this changes to get back the interface?
how to get the eth0 interface as outlined here ?


#9

Hi All,

Now after connecting the IOT module and reseting the gpio , I can see the eth0 interface on the mangOH board.
The modem is connected to cellular base station with data services enabled.
I have run the cfg_gateway.sh to access the internet from laptop connected through rj45 from the IOT connector. Below is the output of cfg_gateway.sh

root@swi-mdm9x28:~# ./cfg_gateway.sh
MangOH gateway configuration
Enter WAN (cellular) interface (default: rmnet_data0):
WAN interface rmnet_data0
Enter LAN interface (default: eth0):
LAN interface eth0
Enter LAN IP (default: 192.168.20.1):
IP address (192.168.20.1)
Enter LAN Net Mask (default: 255.255.255.0):
net mask (255.255.255.0)
Mounting LAN interface 'eth0' IP: '192.168.20.1', net mask: '255.255.255.0'
Check SIM inserted...
SIM card is inserted and unlocked (LE_SIM_READY).

Mounting the relay interface 'rmnet_data0'...
Enabling the radio on 'rmnet_data0'...
Radio power is already set to ON.
Enter APN (default: internet.sierrawireless.com): live.vodafone.com
Enabling the data connection on 'rmnet_data0' using APN 'live.vodafone.com'...
Could not set APN 'live.vodafone.com' for profile 1.
Maybe the profile is connectedCould not set PDP 'IPV4' for profile 1.
Maybe the profile is connectedChecking if device 'rmnet_data0' is up ... ok
Routing inet ... failed
Sun Jan  6 00:07:04 UTC 1980 - RTNETLINK answers: File exists
Waiting for data connection on 'rmnet_data0'...
Relay interface 'rmnet_data0' IP address is '10.149.44.201'
Cleaning IP tables...
Enabling IP forwarding...
net.ipv4.ip_forward = 1
Configuring the NAT...
Configure DHCP server (Y/n): Y
Enter start IP (default: 192.168.20.10):
IP address (192.168.20.10)
Enter end IP (default: 192.168.20.100):
IP address (192.168.20.100)
Reconfiguring the DHCP server...
stopping DNS forwarder and DHCP server: dnsmasq... no /usr/bin/dnsmasq found; none killed
UNABLE TO STOP THE DHCP server

But I cannot access the data services on laptop through IOT Module. Below is the ethernet network interface output.

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::d5eb:d504:5c03:a0db%14
IPv4 Address. . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Did I miss something in configuring the board correctly ?
Any help is greatly appreciated.

Thanks,
Siva


#10

I tried this with a Sierra Wireless SIM and was able to set up the gateway. Check your APN or SIM type, as you are getting an error:
“Could not set APN ‘live.vodafone.com’ for profile 1.”


#11

APN is correct i.e live.vodafone.com

Now i did cm data disconnect and tried, the above APN error disappers, but their is a still failure at the end

SIM card is inserted and unlocked (LE_SIM_READY).

Mounting the relay interface 'rmnet_data0'...
Enabling the radio on 'rmnet_data0'...
Radio power is already set to ON.
Enter APN (default: internet.sierrawireless.com): live.vodafone.com
Enabling the data connection on 'rmnet_data0' using APN 'live.vodafone.com'...
Setting up profile 1
Setting access point name ... ok
Setting packet data protocol ... ok
Setting Authentication ... ok
Connecting ... ok
Checking if device 'rmnet_data0' is up ... ok
Routing inet ... ok
Updating /etc/resolv.conf ... ok
Updating /etc/resolv.conf ... ok
Testing connection ... Waiting for data connection on 'rmnet_data0'...
Relay interface 'rmnet_data0' IP address is '10.238.15.131'
ok
Cleaning IP tables...
Enabling IP forwarding...
net.ipv4.ip_forward = 1
Configuring the NAT...
Configure DHCP server (Y/n): Y
Enter start IP (default: 192.168.20.10):
IP address (192.168.20.10)
Enter end IP (default: 192.168.20.100):
IP address (192.168.20.100)
Reconfiguring the DHCP server...
**stopping DNS forwarder and DHCP server: dnsmasq... no /usr/bin/dnsmasq found; none killed**

** UNABLE TO STOP THE DHCP server**

AT!SCACT?
!SCACT = 1,0

I am not sure whether this setting has to do something with this problem ?

Still there is a problem at the end in generating the configuration file for eth0 for DCHCP server

Thanks,
Siva


#12

@stirulaka,

I do not believe that live.vodafone.com is the correct APN. This is the URL that browsers go to when you have a Vodafone handset for Voda’s internal website.

If you are using a contract SIM on VF then generically speaking you should use ‘internet’ and if you are using a PAYG one then it should be ‘pp.vodafone.co.uk’.

I have given an example of starting a session off using Vodafone below and showing it has connectivity (by pinging Google).

root@swi-mdm9x28-wp:~# ifconfig
bridge0   Link encap:Ethernet  HWaddr 56:9C:28:D3:4B:B3
          inet addr:192.168.225.1  Bcast:192.168.225.255  Mask:255.255.255.0
          inet6 addr: fe80::549c:28ff:fed0:48b0%1237131004/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:76 (76.0 B)

ecm0      Link encap:Ethernet  HWaddr FE:59:AF:80:93:E4
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::fc59:afff:fe80:93e4%1237131004/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:193 errors:0 dropped:4 overruns:0 frame:0
          TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20724 (20.2 KiB)  TX bytes:8548 (8.3 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1%1237131004/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:76 (76.0 B)  TX bytes:76 (76.0 B)

rmnet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:2000  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~# cm radio status
Power:                         ON
Current Network Operator:      vodafone UK
Current RAT:                   LTE network (LE_MRC_RAT_LTE)
Status:                        Registered, home network (LE_MRC_REG_HOME)
Signal:                        Good signal strength (3)
PS:                            Packet Switched Registered, home network (LE_MRC_REG_HOME)

root@swi-mdm9x28-wp:~# cm data apn pp.vodafone.co.uk
root@swi-mdm9x28-wp:~# cm data connect&
root@swi-mdm9x28-wp:~# Setting up profile 1
Connecting ... ok
Checking if device 'rmnet_data0' is up ... ok
Routing inet ... ok
Updating /etc/resolv.conf ... ok
Testing connection ... ok

[1]+  Done                       cm data connect
root@swi-mdm9x28-wp:~# ifconfig
bridge0   Link encap:Ethernet  HWaddr 56:9C:28:D3:4B:B3
          inet addr:192.168.225.1  Bcast:192.168.225.255  Mask:255.255.255.0
          inet6 addr: fe80::549c:28ff:fed0:48b0%1237131004/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:76 (76.0 B)

ecm0      Link encap:Ethernet  HWaddr FE:59:AF:80:93:E4
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::fc59:afff:fe80:93e4%1237131004/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:504 errors:0 dropped:4 overruns:0 frame:0
          TX packets:257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:48852 (47.7 KiB)  TX bytes:40592 (39.6 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1%1237131004/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:76 (76.0 B)  TX bytes:76 (76.0 B)

rmnet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:2000  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1136 (1.1 KiB)  TX bytes:1026 (1.0 KiB)

rmnet_data0 Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:10.31.70.123  Mask:255.255.255.248
          inet6 addr: fe80::28fc:d183:3ddd:2b4f%1237131004/64 Scope:Link
          UP RUNNING  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1084 (1.0 KiB)  TX bytes:1026 (1.0 KiB)

root@swi-mdm9x28-wp:~# ping -I rmnet_data0 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=119 time=40.232 ms
64 bytes from 8.8.8.8: seq=1 ttl=119 time=37.547 ms
64 bytes from 8.8.8.8: seq=2 ttl=119 time=37.174 ms
64 bytes from 8.8.8.8: seq=3 ttl=119 time=35.663 ms
64 bytes from 8.8.8.8: seq=4 ttl=119 time=34.018 ms
64 bytes from 8.8.8.8: seq=5 ttl=119 time=32.557 ms
^C
--- 8.8.8.8 ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 32.557/36.198/40.232 ms
root@swi-mdm9x28-wp:~#

Regards

Matt


#13

Hi Matt,

Have you run cfg_gateway.sh and are you able to access the internet from the laptop using IOT card ?
From your message, I understand that you are trying directly from the mangOh evaluation console.

Thanks,
Siva


#14

@stirulaka,

No because I do not have the card to play with.

I am just trying to confirm you have actually got internet connectivity through the WWAN connection given I beleive you are not actually using the correct APN in the form of live.vodafone.com and you should be using one of those I specified in my post.

Regards

Matt


#15

Hi Matt,

Thanks for your support. I am able to access internet using the IOT card. Below is my setup

  • I had changed the pdp to ipv4v6
  • installed windows driver skylight
  • APN remains same as live.vodafone.com
  • Configured the ipaddress in windows manually .

We can close this ticket now. Once again thanks for your support.

Thanks,
Siva