Unable to get Positioning fix with LAF 17.10


I used the example position on demand application that is available in the documentations. This was working on the MangOH red with LAF 17.07 using an active antenna (passive antenna was pants). But since migrating to 17.10 I can no longer get a fix. What has changed in the positioning components? I can’t go back to 17.07 since my application doesn’t work with the le_data api of 17.07.


Have you tried with AT commands as mentioned in this post

There should really be no change between 17.07 and 17.10 that might cause this issue.


Didn’t go though the lot but this is what looks out of place so far

Current time: 2017 12 28 3 22:32:30

2017 12 28 3 22:30:35 Last Fix Status = FAIL, FAILCODE = 9
2017 12 28 3 22:31:35 Fix Session Status = ACTIVE

No TTFF available



I had done no other software modifications other than update the LAF so it was my primary suspect. it could be the hardware, but the same response is being shown on two mangOH Red boards


So you never get a fix or dont get a fix as quickly as before? Do you have clear visibility to sky?


no I don’t get fix at all. Yes I have clear sky. I have tried it on two different boards



I have just plugged my unit in and it started working happily with 17.11 (again very little difference between 17.10 and 17.11). Things to double check.

  • Bias voltage on the antenna connector to make sure the LNA is actually running.

  • How are you starting the GPS session? Mine is set to autostart as per below.

  • Fail code 9 is ‘user ended the session’ so either there was a Legato or AT command sent to stop it or the session timed out because it could not find a fix within its time limit.

    enable: 2
    fixtype: 1
    maxtime: 180 seconds
    maxdist: 50 meters
    fixrate: 1 seconds