Unable to get GPS fix


#1

I’m trying to get a basic GPS location, but I’m not able to get a fix. The board is finding satellites, but when I try ‘gnss fix’ it times out.

I’ve tried changing the constellation and agps modes, but no combination of these has worked.

‘AT!GPSSATINFO?’ shows that it is detecting satellites:

AT!GPSSATINFO?
Satellites in view: 4 (2017 07 14 4 20:46:48)
SV: 5 ELEV: 0 AZI: 0 SNR: 31
SV: 12 ELEV: 0 AZI: 0 SNR: 19
SV: 24 ELEV: 0 AZI: 0 SNR: 33
SV: 29 ELEV: 0 AZI: 0 SNR: 36
OK

AT!GPSSTATUS? is returning failcode = 12, which is just a timeout error.

AT!GPSSTATUS?
Current time: 2017 07 14 4 20:47:03
2017 07 14 4 20:44:01 Last Fix Status = FAIL, FAILCODE = 12> 2017 07 14 4 20:44:01 Fix Session Status = ACTIVE
No TTFF available

I also did find this on the Legato forums:http://forum.legato.io/t/cant-get-a-location-fix-from-gnss/2219/6, but the solution was to get a different antenna. I’m using the antenna that came with the dev kit, so that shouldn’t be an issue.

Has anybody here come across similar issues trying to get GPS data?


#2

Hiya,

I’ve also had trouble with the GNSS and the antenna that came with the dev kit. Apparently in some cases there is more signal loss through the CF3 socket than expected and the antenna supplied with the kit will not work reliably.

I was advised to use a better antenna - I used one with an active amplifier in the antenna itself - and had no further issues.

And looking at the sat info you provided, all SVs have an elevation and azimuth of 0 - which looks to me as though the GNSS is receiving enough signal to identify the SVs, but not enough to resolve a position for each one. I guess the GNSS is confused as all SVs appear to be in the same place and the maths is just not working…

So, if you can, please try a better antenna - I recommend one that is an ‘Active’ antenna (with the LNA in the antenna to amplify the signal before it gets to the board).

ciao, Dave


#3

hi,
you can reference to the link:


#4

Thanks for the feedback. @davidc My issue does seem like it’s related to using the kit antenna. Compared to my phone’s GPS fix, the Mangoh does not see nearly as many satellites.

I also found I was more likely to get a successful fix using direct AT commands than with using Legato. I would like to try it out with an amplified antenna.


posDaemon - Bad position indication