Unable to download file larger than 100k

I am trying to download file via curl, with system() call:
system("curl ftp://speedtest.tele2.net/1MB.zip --output /home/root/test.file --silent")

Every time i try I get:
Aug 3 13:40:52 swi-mdm9x28-wp user.err Legato: =ERR= | MyAppName[8254] | File size limit exceeded (core dumped)

I tried different settings in the .adef
sandboxed: false
maxFileSystemBytes: 150000K ← many different values tested
maxFileBytes: 200K

But no matter what I set downloading process always stops at 100 KB.
Also I tried writing curl ftp://speedtest.tele2.net/1MB.zip --output /home/root/test.file --silent to a test.sh file and running it as executable. It works when I call it from CLI, it doesn’t work when i call it from code.
I tried to write the file to the /home/root/ directory, but also to the /tmp folder. What am I doing wrong?

no problem is found for WP76 FW R13.

I run a unsandboxed legato application “hello1”:

#include “legato.h”

LE_INFO("Hello, world.");

root@swi-mdm9x28-wp:~# app status
[running] atAirVantage
[running] atQmiLinker
[running] atService
[running] audioService
[running] avcService
[running] cellNetService
[running] dataConnectionService
[running] fwupdateService
[running] gpioService
[running] modemService
[running] portService
[running] positioningService
[running] powerMgr
[running] qmiAirVantage
[running] secStore
[stopped] smsInboxService
[stopped] spiService
[running] tools
[stopped] voiceCallService
[stopped] wifi
[stopped] wifiApTest
[stopped] wifiClientTest
[running] wifiService
[stopped] wifiWebAp
[stopped] hello1
root@swi-mdm9x28-wp:~# ls /tmp
hosts             legato_logs       sdOutput          tmpfdbtable.txt
ld.so.cache       pkgdwl            sock0
ld.so.conf        psm_socket        test.sh
legato            resolv.conf       thermal_engi_ipc
root@swi-mdm9x28-wp:~# cat /tmp/test.sh
curl -o /tmp/data.bin

root@swi-mdm9x28-wp:~# app start hello1
root@swi-mdm9x28-wp:~# ls -l /tmp/data.bin
-rw-------    1 root     root        512000 Aug  3 23:26 /tmp/data.bin

I am running mangOH Red wp76 - FW=R13.3, Legato=20.04.0,

I tried your example:

sandboxed: false

executables: {
    hello1 = ( hello1Component )
processes: {
    run: {
        ( hello1 )


#include "legato.h"

LE_INFO("Hello, world.");


curl -o /tmp/data.bin

And I still got:

Aug  4 10:30:16 swi-mdm9x28-wp user.err Legato: =ERR= | hello1[4226] | File size limit exceeded (core dumped)
Aug  4 10:30:16 swi-mdm9x28-wp user.info Legato:  INFO | hello1[4226]/hello1Component T=main | hello1.c _hello1Component_COMPONENT_INIT() 6 | Hello, world.

I tried fresh reinstall of the filesystem. Nothing helps, file is still limited to 100KB.

you can try mangOH Red wp76 - FW=R13.3, Legato=19.2.0, I don’t see problem with that.

I cannot compile SDK for WP76 (Release 13.3 + Legato 19.02.0), because:

/home/pawel/project/redWorkspace/mangOH/shared.sdef:11:48: error: File '/home/pawel/project/redWorkspace/leaf-data/TEST2/wp76-legato/modules/WiFi/wifi.sinc' not found.

But I tried SDK for WP76 (Release 16 + Legato 19.11.2) stable version and it didn’t help.

Why does this relate to mangoh shared.sdef?