Unable to connect to MangOH green WP7700


#1

Hi I installed the WP7700 on MangOH green dev kit. However, I am not able to communicate to it.

I don’t have A SIM card but , I thought I will be able to login to the module over SSH using 192.168.2.2 but I can’t ping that either.

I found the instructions below to upgrade the firmware of the module.
https://source.sierrawireless.com/resources/legato/drivers-for-wp75xx_wp76xx_wp8548-series-modules---build-4773/

I installed the exe but It doesn’t do anything after installation.


I also found the instruction where it talks about downloading driver but I don’t see any device with Sierra wireless being populated under device manager/hardware.

http://mangoh.io/uploaded-documents/Reference/mangOH%20Green/Discover/Hardware%20User%20Guide/mangOH%20Dev%20Kit%20User%20Guide%20-%20HTML5-Responsive%20HTML5/#t=mangOH_Dev_Kit_User_Guide_-_HTML5%2FSoftware%2FSoftware.htm

I don’t get where do I connect USB? is it USB male to male connector I have to connect the Dev kit to my windows machine?

I even tried connecting my router’s Ethernet cable to the KIT, but I don’t see any LED on the Ethernet port on either side.

This is very basic, my sincere apologies for bugging on this. But, I am stuck.
I would really appreciate your help.


#2

can you pull pin 7 of SW401 high and retry firmware download?


#3

I tried it but it didn’t work.


#4

I have tried quite a few things so far.

  1. Started from scratch following the user guide.
  2. Removed and reinserted the module
  3. Connecting Ethernet
  4. Changed USB cables (Power cable with Data cables)
  5. set the pin 7 to high while attempting to download the firmware but it still doesn’t find the Adapter or Port.
  6. The device manager doesn’t populate sierra wireless com port at all when GenericDriverSetup for USB is installed with USB cable attached.

Any suggestions?

I just see one power LED green on the board and sometime an LED close to serial console adapter blinks once in a while (not on all power up).

Any way to confirm that the module is alright ? or any other way to breakinto the system to get something going?


#5

One more important thing I observed is that W_DISABLE LED is not turning on at all making me believe that the CF3 module is not working as expected or there is something I am missing completely.

Let me know your comments to trouble shoot this.


#6

Hi All, i have same issue with this ticket. I was using WP7702 and I already followed the instruction of the document “Getting Started with mangOH”. But still my device could not be detetcted. I already try same way as @hposhtiw did by using ethernet cable but could not connect.

does anyone know how to handle this issue?


#7

@hasbif39, this is probably not helpful, but I frequently accidentally use a WP8548 cover to install a WP77 on my mangOH, and because the WP8548 is taller, the cover doesn’t put enough pressure on the WP77 and the contact with the socket is compromised. If you’re stuck with only one cover, I’ve placed a small piece of folded paper under the cover just to increase the pressure.

If that’s not it, could you confirm my understanding that you have no USB interfaces showing up in Windows device manager (for example, or no Sierra device in your Linux enumerations, etc). Are you getting any activity with the Console UART interface (DB9 on Green, micro-USB on Red)?


#8

I also had the wrong cover hence it didn’t work, but once I placed the right cover it worked as described in the getting started guide.