TouchSensor Demo - No LED Action


#1

Hello,

I have tried to get the TouchSensor sample app to run on the mangOH board but I am having some issues. I can compile and load the program onto the board with no issue. Also when I run “app status” in the terminal I can see the app is there but stopped. I can also start the app using “app start TouchSensor”. But when I press SW200 I do not see any LEDs turning on. Also there is no LED on the board labeled D750. I have checked the schematics and there is no D750 there but there is a D705…

As I am working to get the demos working so I may learn from them help would be much appreciated in getting this one running.

Thankfully
Kas


#2

Hi Kas,

I think the problem could be that you do not have a jumper installed on CN900 aka GPIOEXP_INT2. We plan to update the README for the code to indicate this. Without this jumper, the interrupt from the button press will not be propagated. Please let me know if this solves the problem for you.


#3

Hello @dfrey,

Thank you for your help. I have installed the jumper and the demo now works when run from the Terminal. If, however, I follow the instructions from a different topic or here and instead try run this perticuler project through DS the LED does not blink. It should be noted that I have not had the same issue with timerLed, that project works fine through DS.

I have checked that the app is installed on the board and that it is running, still no luck.

Kas