The low power mode of WP7605

Does wp7605 have an auto suspend mechanism?
Because only the debug console is connected, it seems that there will be no response due to entering suspend (dmesg message is as follows)

[ 64.408601] Freezing of tasks aborted after 0.008 seconds
[ 64.503073] Freezing of tasks aborted after 0.009 seconds
[ 64.629427] PM: Some devices failed to suspend, or early wake event detected
[ 64.742489] Freezing of tasks aborted after 0.009 seconds
[ 64.854391] Freezing of tasks aborted after 0.009 seconds
[ 64.959135] Freezing of tasks aborted after 0.009 seconds
[ 65.925713] sierra_pm_resume, total sleep time = 134, startup_timer expired

and I have run a LED flashing program, it stops after removing the USB cable, and starts normal operation again after plugging in the USB cable

How to enable/stop the power saving mechanism?

I have also checked AT!POWERMODE?
return
!POWERMODE: No request, status=9-PSM disabled

Another problem is that when I connect mangoh yellow to a Linux computer, I can find the 192.168.2.2 device at first, but the device disappears after about ten seconds ( use lsusb to check, device is still connected). Is this also a suspend problem?


System version
Firmware Version: SWI9X07Y_02.37.03.00 73df45 jenkins 2020/04/08 10:59:14
Bootloader Version: SWI9X07Y_02.37.03.00 73df45 jenkins 2020/04/08 10:59:14

If you remove usb cable from pc, it will enter sleep mode, after that the uart console will not have response

Thank you for your reply.

How can I disable this sleep function?
I’ve checked power mode with AT command(AT!POWERMODE?) , but it showed
!POWERMODE: No request, status=9-PSM disabled

It shows that PSM is disable

Did I understand something wrong?

you need to run an legato application to make the module not going to sleep mode:

1 Like

Thanks, this helped me