Swiflash does not work


#1

Hi,

I’m attempting to flash my mangOH Red with WP7603 using swiflash on Ubuntu 16.04, but it says

[ERROR]
No ttyUSB ports detected; please make sure your device is connected and the udev rule is enabled, or try to power cycle the device.

I can flash using fwupdate and also fdt2 on Windows. Any idea why swiflash does not work?


#2

Hi ktanikel,
Refer to swiflash guide:
https://source.sierrawireless.com/resources/airprime/software/swiflash/

Check that a /dev/ttyUSBX serial port is mounted on your system: this will be the DM port, necessary to handle the download.

Are you able to find /dev/ttyUSBx on your Ubuntu PC after plug mangOH red USB?
If unable to find the driver, may worth to try install:
https://source.sierrawireless.com/resources/airprime/software/usb-drivers-linux-qmi-software-s2,-d-,31n2,-d-,50/

Hope it helps.


#3

Hi @ktanikel
Did you install swiflash using apt?
If not, you’ll need to install the udev rules manually (check swiflash --help for the instructions).
Another though: if you install swiflash (or setup the udev rules as explained above) while the device is already plugged in, you’ll need to plug it out and back in (or power-cycle it), to get the /dev/ttyUSBx ports correctly configured.


#4

@daav, yes I installed swiflash using apt and I can see that the udev rules are in place. But there is no /dev/ttyUSBx device.

@lotam There is no /dev/ttyUSBx. I tried your link, but are there any instructions I can find on how to build and install those drivers? I’m able to build ‘GobiSerial’ but not ‘GobiNet’.


#5

Hi @ktanikel
Please try install GobiSerial which is the driver for /dev/ttyUSBx.

cd GobiSerial
make
sudo make install

On next power cycle, it should enumerate the /dev/ttyUSBx port.

Thx


#6

Mmm, I’m not sure adding the device drivers would help in any sense if there are not already /dev/ttyUSB ports enumerated.
I mean, this is proven to work on a default Ubuntu setup without custom drivers.

So to me:

  • either your host system is specific in any way… Did you tried the board on another computer?
  • or your device has some troubles… Can you ssh to it? Which FW/Legato version is actually running on it?

#7

@lotam , I was able to install GobiSerial and now can see /dev/ttyUSBx. swiflash also works now!

@daav, my host system is a standard Ubuntu 16.04 installation. As mentioned, I tried the board on a Windows computer using fdt2 which worked. I installed the VM from mangOH on that same Windows computer but couldn’t use swiflash from within the VM. I can ssh into it and its running Legato 18.04 with the latest firmware from Sierra Wireless.

Firmware Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02

Thank you for your help.


#8

Hi @ktanikel

ok, I didn’t catch that you were running in a VM!
Indeed, swiflash is not supposed to run from within a VM, as it implies a device reset (which leads to a new enumeration) and this is kind of a risky operation when sharing the USB connection from the Windows host to the Linux guest.

That being said, it’s good to know that it (unexpectedly!) works when you install the GobiSerial driver.


#9

No, it doesn’t work on the VM. It works on my native Ubuntu machine. To be clear,

Native Ubuntu 16. 04 before installing GobiSerial -> Does not work.
MangOH VM on a Windows host -> Does not work.
Windows with fdt2 -> Works.
Native Ubuntu 16.04 after installing GobiSerial -> Works.


#10

Hi @ktanikel

ok, so it’s really an unexpected behavior on your native host…
If at anytime you reproduce the issue again (so without the GobiSerial driver installed), please post content of /var/log/syslog to help for better understanding of the issue…
Thanks!