Starting Apps when battery connected


I was wondering how I may SSH into the Mangoh Red if its running on battery so that I may start monitoring and executing apps.

I’m assuming that the battery can’t be set as the main source of power, or is there a way to do this?


Battery can be set as main source by
a. Removing jumper on CN804… Basically, there is no jumper.
b. If jumper is there, then dont connect to power source.

Once you connect a battery, it can be either the main source or a supplemental power source. Battery supported is Lithium Polymer/Lithium Ion by default.


I’ve tried to both connecting the battery with and without the jumper on CN804, but the device is still not turning on. The battery im using is a EVE ER17505 Lithium Thionyl Chloride 3.6V, and I have with a voltmeter checked that the battery is new. Doesn’t the device support Lithium Thionyl batteries? This battery is not rechargeable.


We only support Lithium Polymer/Lithium Ion… To support other battery types you need to make hardware mods.


Ok. Thanks for the reply.


Will the Mangoh Red get a new IP address when it’s main power source is the battery and the CF3 micro-USB connector? @asyal How do I check the new IP address if so?


I think I found this out by cm data connect and then the new IP will be shown in cm data. I guess there are some security reasons in the rmnet0 why you can’t ssh into the device.


You can modify the firewall rules in /etc/iptables/rules.v4 if you want to enable ssh access on rmnet0