SSH Login with RSA key Problem


#1

When i am trying to login with RSA key. It showing the below message.

Please help me to resolve the issue. I also disabled the console path.


#2

Do you have multiple boards or modules that you are connecting to with a single computer?

I put this snippet in my ~/.ssh/config to eliminate the nagging caused by connecting to many different boards (all of which are at IP 192.168.2.2)

Host 192.168.2.2
    StrictHostKeyChecking no
    UserKnownHostsFile=/dev/null
    LogLevel ERROR

#4

@dfrey Thans for the reply,
mail1
I am unable to login after the following procedure,

Step 1: ssh-keygen -t rsa
mail2
step 2: ssh-copy-id -i ~/.ssh/id_rsa.pub root@192.168.2.2

It shows permission denied.

Please help me resolve this issue…

Thanks,
Raj


#5

Just read the message again. It gives you the command to fix the problem. Type on your terminal the line that starts with "ssh-keygen… "


#6

@leoheck I tried lot of times… but problem not solved… if you have any other suggestion, pls let me know…


#7

Try using sudo before the command


#8

Sure I have.

If you are in linux, open ~/.ssh/known_hosts

And delete a line that has 192.168.2.2 on it.

You can also delete the file itself.


#9

@leoheck Thanks… Tried those ideas… But Not Resolving


#10

@asyal
Thanks… I think you are helping me a bit… by adding sudo command the key saved in root/.ssh/id_rsa.pub

But unable to copy the key from root…

Please suggest me, how to navigate to root folder…

Thanks
Raj