SSH Connection Drops out


#1

I’ve just updated my MangOH Green as outlined here. I’m now attempting to run ANY application on it with some interesting results.

I first attempted to use GPSPublish but that caused an error, thinking it might just be that one application I have now also tried TimerLed with teh same results. The steps I’m taking are:

1) cd mangOH/samples/tutorials/mangOH_Green/gpio/TimerLed 2) mkapp -t wp85 timerLed.adef
3)$ app install timerLed.wp85.update 192.168.2.2

Step 3) produces the output:
Applying update from file ‘timerLed.wp85.update’ to device at address ‘192.168.2.2’.
Unpacking package: 100% ++++++++++++++++++++++++++++++++++++++++++++++++++
Applying update: 100% ++++++++++++++++++++++++++++++++++++++++++++++++++
SUCCESS
Done

Unfortunately, once the update is complete I get an output on the SSH terminal:
root@swi-mdm9x15:~# app status
packet_write_wait: Connection to 192.168.2.2 port 22: Broken pipe
mangoh@mangoh-virtualbox:~$

it then takes a while for the board to reset itself so that you can once again SSH into it. Once done I see that the application that should have been updated/installed is not there.

any help getting this back to where its usable would be very much appreciated.
Kas


#2

Hello Kas,

A. Your application crashes and rolls back
I think it is happening in your case. Are you sure you are using the latest firmware? (check with cm info) Did you install the Mangoh green wp85 package(i am not sure if what GPSPublish and TimerLed application does, maybe it needs gpioExpander Service) ? try with the simple Hello World application first!

B. USB communication problem
If you are using Ubuntu try to disable ModemManager, that can cause problems
I see you are using virtualbox (ist it the official mangoh image?) and you are on Win10 host, I noticed that windows tends to mess with the modem and tries to control it. Making the situation worse, i suspect there has been recently changes with the updates. Actually, i have both tried the USB pass over and the bridge mode on virtual ethernet interface and have some intermittent communication problems with both. Actually, i plan to look into this issue tomorrow as i have some ideas. I will let you know about the result.
I have no problem on native linux.


#3

Hello @tomalex,

I have just downloaded the latest firmware and the newest VM (no updates applied) and I’m still having the same issue. The applications I’ve tried are TimerLed and HeartbeatRed, both produce the same result. I’m not sure what else I can try to get around this issue, but as it stands there is no way for me to develop any applications because I cant load them or test them.

If you have any further suggestions please let me know.

Kas


#4

Hello @tomalex,

Looks like the issue is power related. While I could not verify this for certain (don’t have a USB power monitor) I can confirm that when I plug in a backup battery (that will supplement any power needs) the unit does not restart, at least I could not get it to do so.

Kas