SPI1 data on WP76xx

#1

Hi,

I am getting following error whenever I try to send data on /dev/spidev1.0 (which I assumed is spi1 master connected to IoT Expansion card slot :

[ 184.364669] spi_qsd 78b7000.spi: msm_spi_clock_set: no match found for requested clock frequency:96000

[ 184.392745] spi_qsd 78b7000.spi: msm_spi_process_transfer: Error setting QUP to reset-state

[ 184.400608] spi_qsd 78b7000.spi: msm_spi_clock_set: no match found for requested clock frequency:96000

[ 184.409353] spi_qsd 78b7000.spi: msm_spi_process_transfer: Error setting QUP to reset-state

[ 184.434721] spi_qsd 78b7000.spi: msm_spi_clock_set: no match found for requested clock frequency:96000

[ 184.460286] spi_qsd 78b7000.spi: msm_spi_process_transfer: Error setting QUP to reset-state

[ 184.468324] spi_qsd 78b7000.spi: msm_spi_clock_set: no match found for requested clock frequency:96000

[ 184.487039] spi_qsd 78b7000.spi: msm_spi_process_transfer: Error setting QUP to reset-state

[ 184.496585] spi_qsd 78b7000.spi: msm_spi_clock_set: no match found for requested clock frequency:96000

[ 184.505272] spi_qsd 78b7000.spi: msm_spi_process_transfer: Error setting QUP to reset-state

Any help/suggestion will be very useful.

/dev/spidev1.0 is linked to /sys/bus/platform/drivers/spi_qsd, how to get spidev ( driver for SPI1 to be linked to one of a device file).

regards
ss

#2

We are connecting IOT connector board ( SPI Slave) to mangOH red WP76xx, for which I feel we need SPI1 master to be up and running . I am unable to get a device for spidev for SPI1 in legato up.

As per discussion, at WP7702 using SPI, I was able to re-direct SPI2 to RPi connector using spidev, but we are interested to get SPI1 => IOT connector working.

I have installed sierra wireless R10.1, release greater then this seems to have an issue with updates.
Any thoughts/help will be useful.

#3

Able to fix the issue by setting the clk to 4.8Mhz and activating gpioPin2 (brings IoT card out of reset).