Setup MangOH for Arduino Use


#1

I am trying to follow the instructions found in the “4119370_mangOH Green Tutorial - Arduino to AirVantage_r1” PDF but having issues on page 10 step d.

mangoh@mangoh-virtualbox:~$ echo “export PATH=$PATH:~/git-repo” >> .bashrc
mangoh@mangoh-virtualbox:~$ . ~/.bashrc
Modules: wp85, wp750x
SDK Path: /home/mangoh/legato/packages/legato.sdk.16.7.0.wp85-wp75-native-x86_64-201609301633
Framework Path: /home/mangoh/legato/packages/legato.framework.16.7.0.201609081601 - $LEGATO_ROOT
Toolchain Path: /home/mangoh/legato/packages/legato.toolchain.1.7.3.fw_SWI9X15Y_07110900-wp85-wp750x-native-x86_64-201608171142 - $WP85_TOOLCHAIN_DIR $WP750X_TOOLCHAIN_DIR
Device Image Path: /home/mangoh/legato/packages/legato.device.image.7.11.9.00.wpX5-201609121138 - $WPX5_DEVICE_IMAGE
Recovery tools Path: /home/mangoh/legato/packages/legato.recovery.4.0.0.linux-201607191626 - $WPX5_RECOVERY
No toolchain found for target ‘ar7’.
Unable to find compatible cross-build toolchain for target ‘ar7’.
No toolchain found for target ‘ar86’.
Unable to find compatible cross-build toolchain for target ‘ar86’.
/home/mangoh
“export: command not found

That is the input and the error returned. Any help would be very much appreciated.

Thanks
Kas


#2

Hi Kas,

Are you running the commands above under Linux? Are you running a shell other than bash?

Thanks,
David


#3

@dfrey

I have attached a screenshot that hopefully explains exactly what it is I was doing.

Thankfully
Kas


#4

Hi @Kas.Lewis

There is probably an issue with the quotes characters when copy-pasting from the PDF.
Should be ""
But if you look carefully, you used “” (not the same characters).
And these ones are not understandable by bash.


#5

I think @daav is correct. I think that document may have been authored in Microsoft Word and Word has a horrible feature where it replaces regular ASCII quotes with fancy unicode quotes.


#6

It looks like that was part of the issue. I’m guessing now though I have an extra PATH variable that I need to remove but I’m not sure how. Here is an updated screenshot.

Kas


#7

open /home/mangoh/.bashrc in a text editor and remove any problematic lines at the bottom of the file.


#8

I could not find the file at “home/mangOH/.bashrc” I instead found it at “home/.bashrc”. I have tried removing any thing unwanted at he bottom but I’m still getting an error.

I have rerun the command – echo “export PATH=$PATH:~/git-repo” >> .bashrc – and the results in the file are:

But I still get the same error.

Kas


#9

I think there might be a problem with shell expansion before the output is reaching the .bashrc file. Please open the file in an editor and add the following line at the bottom:
export PATH=$PATH:~/git-repo

Delete the lines that have been added previously.


#10

Hi Kas,

Just a side note that there’s an error in step f), the url should be “https://github.com/mangOH/manifest” instead of “https://github.com/mangOH/manifests


#11

I tried adding that line and still not working :frowning:

I also changed theline to “export PATH:~/git-repo” (I think) and now bash can’t find VIM to edit the file again :frowning:


#12

Can you paste this
export PATH=$PATH:~/git-repo

you are pasting export PATH:~/git-repo


#13

BTW, can you follow the steps here

This build your mangOH git properly. The git structure has changed since the arduino doc was written and the steps listed on this page work.