redSensorToCloud doesn't start after reboot automatically


#1

Hello,
redSensorToCloud doesn’t start after reboot automatically.

at first I set startManual to true
root@swi-mdm9x15:/# config set legato/systems/current/apps/redSensorToCloud/startManual true bool
root@swi-mdm9x15:/# config get legato/systems/current/apps/redSensorToCloud/startManual
true
after reboot, I get status stopped.
root@swi-mdm9x15:~# app status redSensorToCloud
[stopped] redSensorToCloud

any idea, how to solve this issue?


#2

can you show the logread -f info?


#3

Hey @AE_1,

Instead of doing this from the config tree, maybe it would be better to specify this in the corresponding .adef file (the one in the MangOH repo is set to manual start). For the redSensorToCloud app, you could do this by forking the repository or writing your own .adef file that points to the existing redSensorToCloud source. We ended up forking it since our changes have become pretty dramatic. If you need a hand getting either of these options setup please let me know and I can put an example on GitHub.

Also keep in mind that an app may sit waiting for required IPC API’s to connect, so be sure that all apps specified in your app’s .adef bindings section are running.

Cheers