redSensorToCloud doesn't run


Hi All,
I have compiled the demo find on rev.3 UM “mangoh-Red”, the app running well, but when I try to start the redSensorToCloud app, the system answer that the app is not installed…
If I try to start other apps, they running …

Do You have any idea about the solution?

Thanks so much


I am new to all of this buuuuuut maybe try uninstalling and reinstalling redSensorToCloud app?

Here is the page that explains how to install/uninstall apps:

Here is the gitHub link to the app:


can you see what response you get for
cm radio


Hi asyal,

I am having the same issue. Using cm radio i get the following:

It is registered to the home network yet the name of the network operator does not show.

I also get the following message in the log:
Nov 7 07:38:28 | supervisor[476]/supervisor T=main | app.c CreateFileLink() 1461 | Could not stat file at ‘/sys/devices/i2c-0/0-0068/iio:device0/in_accel_x_raw’. No such file or directory

I check the directory tree and found that 0-0068 is missing. There are four directories that have the same structure. They are:

any thoughts?

Kind regards,



I am tried to install/uninstall the app, but had the same result.
The cm radio command is:



@lekallalek assuming you have installed the mangOH enviroment properly, can you try this on your host:

  1. make clean
  2. make red_wp85
  3. instsys mangOH_Red.wp85.update
  4. check unit now

Key is to do all in the right sequence.


Hi Asyal,

I re-tried it and now is running … thanks a lot.

a question: the GpioexpanderserviceRED app is not present in the “app status” list … do You have any idea about it?



The IoT slot kernel module was enabled recently and it conflicts with gpioExpanderServiceRed. There is a problem where the GPIO expander GPIOs either need to be controlled by the kernel or by a userspace driver. Due to software design issues, the GPIOs are not available to userspace when they are controlled by the kernel driver. There has been some talk about trying to fix this, but I don’t know when it will happen.


Thanks for the info David, I hope that this bud will be fix ASAP.
Please, when done can You inform me/us?

Have a nice work.




Why do you need the user space app? Please explain. You can disable to the IoT Kernel module and use the user space app.



I need to realize e simple test with the temperature sensor on mangoh-red board and send the data to airvantage for viewing them… very simple I suppose.



you dont need the gpioexpanderservice for that.


Yes, I know.
I have put in run avcService app and the system is updated on the airvantage web now




@aysal thanks for the steps. the app is running now.

AirVantage cannot see the device and there is no communication between the device and AirVantage.

cm data and cm info give the following information

Any ideas as to why there is no communication?

I uploaded a copy of the log file for reference.

Kind regards,

Pierrewp85 log.txt (73.1 KB)


Hi Pierre,

I think that the APN is wrong, it must be
attached my screenshot




That fixed it for me.

The fact there is a value in the APN field does not mean it is the right one - I had “Broadband”

Use “cm data apn” (no quotes).
Now I just need to get the AT commands working…


Hello Enrico,

I hope you are doing fine.

I changed the APN and still it did not work. I am now thinking about changing the SIM card and see if it works.

Thanks for the suggestion.

Kind regards,




I changed the SIM card and the device connected to AirVantage. I ran redSensorToCloud without being able to see the data on AirVantage. I am going to dig deeper into this.

Kind regards,