Red_wp85 Developer Studio errors


#1

Hello

I have a problem with making new project in Developer Studio.
I made new Legato Application and after build i had:


Then I follow steps from here: https://github.com/mangOH/mangOH/blob/master/README.md and here: https://forum.legato.io/t/adding-newest-version-legato-framework-into-developer-studio/2654 but still same errors after build.

I’m working on virtual machine.

root@swi-mdm9x15:~# fwupdate query
Connecting to service …
Firmware Version: SWI9X15Y_07.13.07.00 92cfd2c jenkins 2018/08/22 19:18:52
Bootloader Version: SWI9X15Y_07.13.07.00 92cfd2c jenkins 2018/08/22 19:18:39
Linux Version: 3.14.29ltsi-yocto-standard #2 PREEMPT Sat Aug 4 23:41:40 UTC 2018
root@swi-mdm9x15:~# legato version
18.09.0-1-gd778de83_b9a3b439593ef815bd06ca3b62f531fe


#2

Hi @gadget_dev

This kind of error (skipping incompatible liblegato.so when searching for -llegato) is typically raised when you try to build a project for another module.
I would suggest you to double-check if your project is configured for WP85 module.