Red Sensor to Cloud

I follow to the given get started document. My red mangoH with WP8548 can connect to cloud via “app start redCloud” it can only Gyro info. Other sensors (Light, Pressure, Temperator) cannot be sent to iCloud. Why? what’s wrong?

I can see other value like temperature and pressure.

You can use my mangoh source:

At noon, I tried again temperature and gyro were sent to cloud. This time, I connected 2 USB cables for CF3 and Console. How long typically that we have to wait for entire sensors’ data?

you can check the timestamp in logread and compare with the timing in AVMS timeline

Look at my communication log

There are two type of data were sent in different time.
Light, Pressure sensors are not working yet. The temperature is not updated.

Should I go to reinstall firmware?

The application will post data in different time, you cam have a try on my application

I work on WP8548, is it compatible?

Not sure, normally you need to recompile


Thanks for your help.

I would like to install the apps redSensor and redCloud into mangOH from



A Legato app that publishes sensor data from the mangOH Red to AirVantage using LWM2M - mangOH/RedSensorToCloud

to read the sensor data reading into the Airvantage dashboard.

Could you please help me to know how to install thease two apps into developer studio 5.3.1 and legato is WP76 R12 18.10.3? Thanks.

I used command line to compile mangoh source, never used developer studio for such purpose

thanks, how can i do it via CLI? thanks in advance.

You can refer to here on how to build the legato image for mangoH Red board:

I tried to ''make red_wp85" in your folder in terminal. I got an error message as followed

bonsai@bonsai-desktop:~/WaffleMaker/mangOH_2-7-2019$ make red_wp85
make -C /home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato framework_wp85
make[1]: Entering directory ‘/home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato’
Building Legato for target ‘wp85’
Module: WiFi
Module: Dualsys
KSET /home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato/.config.wp85 - TARGET_WP85
python3: can’t open file ‘/home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato/3rdParty/Kconfiglib/’: [Errno 2] No such file or directory
Makefile:127: build/wp85/ No such file or directory
make[1]: *** [Makefile:384: /home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato/.config.wp85] Error 2
make[1]: Leaving directory ‘/home/bonsai/WaffleMaker/RedMangoH_workspace/WP8548IOT/LegatoSource/legato’
make: *** [Makefile:64: legato_wp85] Error 2

you might need to do a “make clean” first

Please note that I am using the legato package in WP85/WP75 R16.

I did but it still doesn’t work. I reinstalled many times. I found a problem when compiling. My OS is Ubuntu 20.04 which has not ‘python-git’ package, does it matter ? Do I need to change previous version of Ubuntu ?

No idea about Ubntu20.04, never used it before.
I am using Ubuntu14 to compile.