Record reference is un-usable after successful push


#1

Hello all,

We use the le_avdata API “time series records” functionality. In the past, we’ve been able to create a single record reference with le_avdata_CreateRecord(), record to it using le_avdata_Record<T>(), and then push it using le_avdata_PushRecord().

Since upgrading to Legato 18.01, we are unable to record to a given record reference after successfully publishing once. After the successful push, all subsequent calls to le_avdata_Record<T>() fail and return an LE_FAULT. I dug into the source a bit and noticed le_avdata_Record<t>() will return LE_FAULT if the reference is null, however the reference is non-zero at the time of calling le_avdata_Record<t>(). Should I be creating a new record each time or this a bug?

We’re back on 17.11 for now without this issue.

Any help is greatly appreciated!


#2

Hello

I have the same problems…
Not good we lost a lot of time…

Francis.


#3

Hello all,

I just want to make it clear: we are no longer testing Legato 18.01 and are back on 17.11 until this gets resolved. This is too big of a blocker to carry on testing this release. 17.11 definitely is not perfect and we have some less than ideal “solutions” in place to keep it working, but nothing as severe as this.


#4

Hi @nick,

This is a Legato framework issue. Have you tried contacting the Legato team? I sent a message to someone within the Legato team pointing them at this forum post, but I still think it might be a good idea to ask them directly.


#5

Hey @dfrey,

I’ll make some noise on the Legato forum. Thanks for the suggestion.


#6

Hello everyone,

I’m going to be testing this issue against RedSensorToCloud tomorrow (instead of our “forked” version of RedSensorToCloud). I’ll report back with logs and any insight I can gather.


#7

Hello all,

I spent some time trying to get RedSensorToCloud running this morning but I kept running into issues. I had a brief discussion with @dclark75 here about some changes that seemed to be causing issues.

In the interim, here is a gist of our logs with the lines of interest highlighted. Is this similar to the behaviour you observed, @Francis.duhaut?


#8

Yes I was observed the Failed push record too when I used time série.
I go back to 17.11. No time to investigate more. I have another urgent project at this time.


#9

Hello all,

I built Legato from the 18.02-release branch manifest and this seems to be solved. I’m going to try 18.01 again to see if the problem comes back.


#10

Good news. Thank for the feedback.


#11

Hello all,

I’ve been testing Legato 18.02 without this issue. Came back almost immediately in Legato 18.01. I think we can consider this fixed. Sorry I left this dangling for a while, we finally got some new hardware so I was able to test this.