Push Button ( gptio pin 14 ) not permited

I try to find how handle push button to implement some action.

After search on legato and mangoh forum, i’ve never found a correct response.

So i’ve make some test from gpioCf3Demo.

but when i run my application, i’ve this message:

gpioSysfsUtils.c ExportGpio() 151 | Failed to export GPIO 14. Error Operation not permitted

I’ve try to read the gpio available on my 7702 with the AT command

+WIOCFG: 2,16,0,0,1,0,0
+WIOCFG: 4,3,0,0,1,0,0
+WIOCFG: 6,0,0,0,1,0,0
+WIOCFG: 7,16,0,0,1,0,0
+WIOCFG: 8,16,0,0,1,0,0
+WIOCFG: 13,16,0,0,1,0,0
+WIOCFG: 21,16,0,0,1,0,0
+WIOCFG: 22,16,0,0,1,0,0
+WIOCFG: 23,16,0,0,1,0,0
+WIOCFG: 24,16,0,0,1,0,0
+WIOCFG: 25,16,0,0,1,0,0
+WIOCFG: 28,16,0,0,1,0,0
+WIOCFG: 29,16,0,0,1,0,0
+WIOCFG: 30,16,0,0,1,0,0
+WIOCFG: 31,16,0,0,1,0,0
+WIOCFG: 32,16,0,0,1,0,0
+WIOCFG: 33,16,0,0,1,0,0
+WIOCFG: 35,16,0,0,1,0,0
+WIOCFG: 42,16,0,0,1,0,0

But no gpio 14 (push button) not available !

So, how i can use the push button ?

Currently my configuration is:
legato 19.11.2
Firmware Version: SWI9X06Y_02.35.02.00 5208b3 jenkins 2020/06/10 00:30:12
Bootloader Version: SWI9X06Y_02.35.02.00 5208b3 jenkins 2020/06/10 00:30:12

I don’t see there is gpio14 in wp77 product technical specification

But in the mangoh red spécification, the push button is on the gpio 14 !

it is the io14 of the gpio expander sx1509biultrt!!!

Great !

But that doesn’t answer my initial question.

I never used before, but here has an example for reference

Yes, i’ve tested but there is some conflic with the led !
The GPIO of the led give correct response, but but the led does not light up !

Here I have tried to control the SD_SEL pin, it is working fine for me on mangoh red board.

gpioexp 1 1 enable
//To switch SDIO_SEL to SD CARD:
gpioexp 1 9 output normal high >/dev/null

//To switch SDIO_SEL to IOT0 slot:
gpioexp 1 9 output normal low >/dev/null

Also I have tried the following to read the push button value and it works for me:

gpioexp 1 14 input value