Protocol "smtps" is not supported (or) Disabled in libcurl

you can see /home/mangoh/Downloads/yocto/build_bin/tmp/sysroots-uninative/x86_64-linux/lib/libc.so.6 does not have GLIBC_2.27…

yes,i have seen it is not a 2.27 .how to proceed now?

Not sure if you can copy the working one to the build path and make image again.

I got same error,so can you please create the .cwe file and send me,to enable RTSP and RTMP protocols in curl.

how did you copy?
the one in /lib/x86_64-linux-gnu/libc.so.6 should have GLIB_2.7.

i did’t copy any thing,just i searched in google.
sudo apt-get install glibc-source and then tried make image,but i got same error

can you please create the .cwe file and send me,to enable RTSP and RTMP protocols in curl

Then why don’t you copy the library to /home/mangoh/Downloads/yocto/build_bin/tmp/sysroots-uninative/x86_64-linux/lib

Hi someone could please tell me what languages should I learn for making browser extensions?

if i want to add two protocols RTSP and RTMP in curl.what i changes in curl_7.61.0.bb file please help me

Please follow the steps below:

  1. in ./poky/meta/recipes-support/curl/curl_7.61.0.bb, add the rtsp rtmp function like below:
    PACKAGECONFIG ??= “${@bb.utils.filter(‘DISTRO_FEATURES’, ‘ipv6’, d)} gnutls proxy threaded-resolver zlib libssh2 smtp rtsp rtmpdump”

  2. copy the folder ./meta-openembedded/meta-multimedia/recipes-multimedia/rtmpdump/ to ./meta-swi/common/recipes-multimedia/

  3. in ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc, add the following:
    IMAGE_INSTALL_append = " rtmpdump"

  4. make the yocto image and download to your module