Protocol "smtps" is not supported (or) Disabled in libcurl

seems same problem on this one:

I don’t see problem with the following steps:

  1. Go to https://myaccount.google.com/security
  2. Go to “Less secure app access” section
  3. Turn on the access
  4. save the following to /tmp/mail.txt

From: “User Name” username@gmail.com
To: “John Smith” john@example.com
Subject: This is a test

Hi John,
I’m sending this mail with curl thru my gmail account.
Bye!


  1. now in WP module console, type the following:
    curl --url ‘smtps://smtp.gmail.com:465’ --ssl-reqd --mail-from ‘username@gmail.com’ --mail-rcpt ‘john@example.com’ --upload-file /tmp/mail.txt --user ‘username@gmail.com:password’ --insecure

thankyou for your reply
I turned on the Less secure app access,but still Im getting same error

i don’t see problem with my gmail account.
I can receive the email.

Are you run in mangOH board or ubuntu in pc

I run the command in mangoh red board.

root@swi-mdm9x28-wp:/mnt/userrw# curl --url ‘smtps://smtp.gmail.com:465’ --SSL-reqd --mail-from ’
example@gmail.com’ --mail-rcpt ‘sample@gmail.com’ --upload-file mesg.txt --user ‘example@gmail.com:pasword’ --insecure
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- 0:00:02 --:–:-- 0
curl: (67) Login denied
root@swi-mdm9x28-wp:/mnt/userrw#

ss.png

You can leave your test account here, I can try next week.

Finally i slove this problem by using this procedure

In addition to enabling Allow less secure apps , you might also need to navigate to https://accounts.google.com/DisplayUnlockCaptcha and click continue. From there, send a test email on your Drupal site.
thankyou

hi
I need your help like before,now i need to enable RTSP and RTMP protocols.can you please tell me how to enable it?
thankyou

have you tried to modify the curl_7.61.0.bb file attached above and modify the following line to have rtsp?

PACKAGECONFIG ??= “${@bb.utils.filter(‘DISTRO_FEATURES’, ‘ipv6’, d)} gnutls proxy threaded-resolver zlib libssh2 smtp”

hi
In this yocto_wp76xx.4k.cwe here,
Protocols: file ftp ftps http https scp sftp smtp smtps
Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets HTTPS-proxy
so i need to enable rtsp,rtmp and some other protocols,can you please share .cwe source code?

Did you try to modify bb file and build the yocto image?

No,Im tryed as previous one like SMTP protocol,as you suggested in yocto_wp76xx.4K.cwe in Developer studio,in that using flash firmware from external file. but now what you suggested to do in that i do not know i do not know how to build the yocto image. I am very new to this field.

Thank you for helping me

I think you need to start learning how to build the images as i cannot help to build the image for you whenever new FW is released or whenever you have new requirement.

please share any documents about how to build the images

I don’t have document, didn’t i already show you the steps above?

I’m trying to build yocto source(legato-Dist-Source-mdm9x28-SWI9X07Y_02.28.03.05.tar.bz2),but Im getting error during “make image_bin”
Makefile:255: recipe for target ‘image_bin’ failed
make: *** [image_bin] Error 1

How about just type make?

You can install teamviewer and leave your account here, i can go and have a look

I tried for above Make command also im getting same error.
is it depends on ubuntu version? currently im using 18.04.1.