Protocol "smtps" is not supported (or) Disabled in libcurl

I got same error,so can you please create the .cwe file and send me,to enable RTSP and RTMP protocols in curl.

how did you copy?
the one in /lib/x86_64-linux-gnu/libc.so.6 should have GLIB_2.7.

i did’t copy any thing,just i searched in google.
sudo apt-get install glibc-source and then tried make image,but i got same error

can you please create the .cwe file and send me,to enable RTSP and RTMP protocols in curl

Then why don’t you copy the library to /home/mangoh/Downloads/yocto/build_bin/tmp/sysroots-uninative/x86_64-linux/lib

Hi someone could please tell me what languages should I learn for making browser extensions?

if i want to add two protocols RTSP and RTMP in curl.what i changes in curl_7.61.0.bb file please help me

Please follow the steps below:

  1. in ./poky/meta/recipes-support/curl/curl_7.61.0.bb, add the rtsp rtmp function like below:
    PACKAGECONFIG ??= “${@bb.utils.filter(‘DISTRO_FEATURES’, ‘ipv6’, d)} gnutls proxy threaded-resolver zlib libssh2 smtp rtsp rtmpdump”

  2. copy the folder ./meta-openembedded/meta-multimedia/recipes-multimedia/rtmpdump/ to ./meta-swi/common/recipes-multimedia/

  3. in ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc, add the following:
    IMAGE_INSTALL_append = " rtmpdump"

  4. make the yocto image and download to your module

I am followed above steps,but i got only smtp rtsp
i’m not getting rtmpdump.please help me

In module, type " find / -name “rtmpdump*” "
What do you see?

root@swi-mdm9x28-wp:~# " find / -name “rtmpdump*” "
-sh: find / -name “rtmpdump*” : not found

root@swi-mdm9x28-wp:~# curl --version
curl 7.61.0 (arm-poky-linux-gnueabi) libcurl/7.61.0 OpenSSL/1.0.2p zlib/1.2.11 libssh2/1.8.0 librtmp/2.3
Release-Date: 2018-07-11
Protocols: file ftp ftps http https rtmp rtsp scp sftp smtp smtps
Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets HTTPS-proxy
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~# find / -name “rtmp
find: /proc/1827: No such file or directory
/usr/bin/rtmpdump
/usr/lib/librtmp.so.0
/usr/sbin/rtmpgw
/usr/sbin/rtmpsrv
/usr/sbin/rtmpsuck

mangoh@mangoh-vm:~$ ssh root@192.168.2.2
root@swi-mdm9x28-wp:~# curl -V
curl 7.61.0 (arm-poky-linux-gnueabi) libcurl/7.61.0 OpenSSL/1.0.2p zlib/1.2.11 libssh2/1.8.0
Release-Date: 2018-07-11
Protocols: file ftp ftps http https rtsp scp sftp smtp smtps
Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets HTTPS-proxy
root@swi-mdm9x28-wp:~# find / -name “rtmp”
find: /proc/2265: No such file or directory
root@swi-mdm9x28-wp:~#

you can check my .cwe file

seems the image is too big as you have embedded “ffmpeg”, please remove ffmpeg and rebuild the yocto image.

Requesting system reboot
[ 365.576888] reboot: Restarting system
[ 365.580355] Calling SCM to disable SPMI PMIØ
Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset), D - Delta, S - Statistic
S - QC_IMAGE_VERSION_STRING=BOOT.BF.3.1.2-00095
S - IMAGE_VARIANT_STRING=LAATANAZA
S - OEM_IMAGE_VERSION_STRING=mktarg-wp76xx
S - Boot Config, 0x000002e1
B - 1216 - PBL, Start
B - 3720 - bootable_media_detect_entry, Start
B - 5007 - bootable_media_detect_success, Start
B - 5011 - elf_loader_entry, Start
B - 8467 - auth_hash_seg_entry, Start
B - 8693 - auth_hash_seg_exit, Start
B - 60077 - elf_segs_hash_verify_entry, Start
B - 107143 - PBL, End
B - 115503 - SBL1, Start
B - 173789 - pm_device_init, Start
B - 193949 - PM_SET_VAL:Skip
D - 18422 - pm_device_init, Delta
B - 195261 - boot_config_data_table_init, Start
D - 0 - boot_config_data_table_init, Delta - (0 Bytes)
B - 204014 - CDT version:3,Platform ID:8,Major ID:1,Minor ID:0,Subtype:129
B - 210938 - sbl1_ddr_set_params, Start
B - 214750 - Pre_DDR_clock_init, Start
D - 213 - Pre_DDR_clock_init, Delta
D - 0 - sbl1_ddr_set_params, Delta
B - 227469 - pm_driver_init, Start
D - 4453 - pm_driver_init, Delta
B - 233752 - cpr_init, Start
D - 122 - cpr_init, Delta
B - 238327 - cpr_cx_mx_apc_vol_update, Start
D - 91 - cpr_cx_mx_apc_vol_update, Delta
B - 253607 - clock_init, Start
D - 152 - clock_init, Delta
B - 253821 - boot_flash_init, Start
D - 39802 - boot_flash_init, Delta
B - 296643 - boot_flash_swi_ddr_init, Start
D - 26901 - boot_flash_swi_ddr_init, Delta
B - 437370 - Invalid PMIC gpio 3
B - 437431 - Invalid PMIC gpio 3
B - 437461 - Failed to configure/read HW ID minor bit 0
B - 442768 - hw_family:5, hw_type:18, hw_rev:12
B - 451430 - SSMEM init OK
B - 452742 - ssmem_get: region 18 not exists
B - 454084 - cannot get SSMEM fwupdate region
B - 475525 - USB non-zero endpoint requirements: 9 in, 5 out
B - 477630 - opening partition 0:SWIFOTA
B - 20217260 - smart recovery counter cleared
B - 24957997 - VERSION=Fri Mar 6 10:30:31 UTC 2020,SIZE 0x2a4ba20, IMG_TYPE=0x8,NON-SPKG/FOTA IMG,SUBIMAGE=SYST,ERROR=Flash write failed: Image size out of range (0X83),STATUS=FAIL
B - 24969313 - API change: date not generated by cwe_header_init
B - 24973949 - API change: date not generated by cwe_header_init

is there any solution to add rtmp

please share your .cwe file

Please follow the steps below:

  1. in ./poky/meta/recipes-support/curl/curl_7.61.0.bb, add the rtsp rtmp function like below:
    PACKAGECONFIG ??= “${@bb.utils.filter(‘DISTRO_FEATURES’, ‘ipv6’, d)} gnutls proxy threaded-resolver zlib libssh2 smtp rtsp rtmpdump”
  2. copy the folder ./meta-openembedded/meta-multimedia/recipes-multimedia/rtmpdump/ to ./meta-swi/common/recipes-multimedia/
  3. in ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc, add the following:
    IMAGE_INSTALL_append = " rtmpdump"
    4.in ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc, DO NOT add the following:
    IMAGE_INSTALL_append = " ffmpeg"
  4. make the yocto image and download to your module

Thank you so much jyijyi
finally i got rtmp.