Problem with HttpServer with latest updates


#1

Hi Guys,

I’ve updated the firmware on my target to release 12.2 and updated the legato build system to 16.10, but I’m having a problem with an app that I developed from the http Server sample - it’s the only app that I build from the command line, not from the windows/ linux IDE’s. I have another component called ‘backend’ along with the lighttp server and everything was working fine until upgrading the firmware. The error that I get is:

serviceDirectory[411]/serviceDirectory_exe T=main | serviceDirectory.c DispatchToServer() 713 | Client (uid 1013 'apphttpServer', pid 4472) disagrees with server (uid 0 'root', pid 431) on protocol ID of service 'backend'

I’ve tried a clean build and re-touching the files but I keep getting this error. Any ideas ?


#2

OK, I have got to the bottom of this.

You get this kind of error when you try to install an app built for 16.7.1 onto the 16.10.1 firmware. On the windows version, if you go to Developer Studio -> Window -> Preferences -> Available Target Platform and select 16.10.1, it doesn’t persist across projects; you have to go to Project -> properties -> Legato Application -> Available Target Platform and select it there. Then everything works fine.


#3

Indeed, in DS, projects are sticking to the Legato “Target Platform” chosen at creation time, until you change that in the project properties.
This allows you to deal with multiple Legato versions in the same DS environment.


#4

I am using Legato-CLI. How can I change that


#5

Can you explain what you are trying to do?


#6

I tried running a MqttClient application on mangoh board. I have legato 18.03.0.
And I got the same error. I have a linux host and I’m compiling through CLI.