Problem when upgrading the WP85xx Firmware Release 12.2


#1

Hello,

I’m using the version that shipped with the Mangoh Green board.

root@swi-mdm9x15:~# fwupdate query
Connecting to service …
Firmware Version: SWI9X15Y_07.08.02.00 r31088 CARMD-EV-FRMWR1 2016/02/05 23:29:29
Bootloader Version: SWI9X15Y_07.08.02.00 r31088 CARMD-EV-FRMWR1 2016/02/05 23:29:29
Linux Version: 3.14.29ltsi-5d7a6bf7c6_ed88cc68b5 #2 PREEMPT Sat Feb 6 02:37:18 PST 2016

root@swi-mdm9x15:~# legato version
16.01.0.Beta_aa0684bddf31f5ea2d457b53d2218972_modified

And tring to upgrade the the firmware to Release 12.2
http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

These are the steps.

At first I installt the swicwe - command line tool (linux host) successfully.

Then try to connect to the Device
root@swi-mdm9x15:~# ls /dev/ttyUSB0
/dev/ttyUSB0
root@swi-mdm9x15:~# ls /dev/ttyUSB*
/dev/ttyUSB0

I think that the device ist connected and then downloaded the swiflash and install it successfully.

Then use the AT!BOOTHOLD with microcom -E /dev/ttyAT command, plug in the device USB cable.

Check the /dev/ttyUSB0 serial port again
root@swi-mdm9x15:~# ls /dev/ttyUSB0
/dev/ttyUSB0

Preliminary checks:
sudo cp $ROOT/99-sierrawireless-modem.rules /etc/udev/rules.d
sudo service udev restart

Finally when I run the command
legato@legato-VM:~$ swiflash -m WP8548 -i $/home/legato/Doenlads/WPx5xx_Rlease-12.2_GENERIC.spk
[ERROR]
No ttyUSB ports detected; please make sure your device is connected and the udev rule is enabled, or try to power cycle the device.

I thought it may be something wrong with the enumerating as DM Port.
Then I use the command configEcm off.

Then it get even worse. At first it cut the connection with the board. But when I plugged in it again. My Internet didn’t work. Before that my Internet(with cable) could work when the unidentified network(CF3 module) existed. But now only I cut connection with the unidentified network then could I get my Internet again.

Please tell me if my steps are wrong.
And the conflict between my Internet and the unidentified network. Is that a problem? What should I do.

Thx a lot.

Genfory


#2

I’m not sure if it matters, but I always do pass -m WP85XX to the swiflash command.


#3

I just upgraded two mangOH boards buy simply downloading the executable from http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/ and in Windows running the exe. takes about 5 minutes or so and then it’s done.

  1. Download
  2. Double click (run executable)
  3. Press enter when done.

It really was surprisingly that simple. I’m working on a log entry that explains the steps I used to get the newest version of Legato up and running with the timerLed demo. This includes upgrading teh firmware as well as teh version of Legato on teh MangOH board. If you like I can link it here when I’m done (hopefully within 24 hours from this posting).

Kas


#4

Hi @genfory,
as @Kas.Lewis says, on Windows hosts, to upgrade your device you need to simply use the standalone exe file from the WP Firmware release pages.
Actually, swiflash is not designed and certainly doesn’t work from within a Linux VM inside Windows (at least without binding all the USB profiles from the WP into the VM…)


#5

Hi @daav,
Thx for ur suggestion…I have tried again with the Windows exe, it works…But when I check the version again, it’s not the 12.2.
root@swi-mdm9x15:~# fwupdate query
Connecting to service …
Firmware Version: SWI9X15Y_07.11.09.00 r32989 CARMD-EV-FRMWR1 2016/08/11 18:03:20
Bootloader Version: SWI9X15Y_07.11.09.00 r32989 CARMD-EV-FRMWR1 2016/08/11 18:03:20
Linux Version: 3.14.29ltsi-c14b887744_0c284d02b3 #2 PREEMPT Thu Aug 11 20:50:27 PDT 2016
root@swi-mdm9x15:~# legato version
16.07.0_cd4985660a55cc9a6f9a2ed28bcc757e

Are these correct?

Thx.
Genfory


#6

Yes, looks correct
Cheers


#7

Hello @genfory,

I have posted a basic tutorial that explains all teh setup for Legato 16.07 that post can be found here

Kas