Problem controlling Pin 15 on Raspberry Pi Connector


I’m trying to control Pin 15 on Raspberry Pi Connector. The schematic shows it as WP_GPIO_8_lvl which goes to GPIO35 on the CP3 module. The bindings section in the .adef file is as follows:
** ledtest4.ledtest4Component.mangoh_ledGpio -> gpioService.le_gpioPin35**

The program compiles fine but when I run it nothing happens and I get the following message:
Missing binding: ledtest4.ledtest4Component.mangoh_ledGpio -> .le_gpioPin35

The program works fine when I try to control Pin 13 on the Raspberry Pi Connector, GPIO23 on CF3 module.

Any ideas to what I am missing?


On the target:

root@swi-mdm9x14~# microcom -E /dev/ttyAT
+WIOCFG: 2,16,0,0,1,0,0
+WIOCFG: 6,16,0,0,1,0,0
+WIOCFG: 7,16,0,0,1,0,0
+WIOCFG: 8,16,0,0,1,0,0
+WIOCFG: 13,16,0,0,1,0,0
+WIOCFG: 21,16,0,0,1,0,0
+WIOCFG: 22,16,0,0,1,0,0
+WIOCFG: 23,16,0,0,1,0,0
+WIOCFG: 24,16,0,0,1,0,0
+WIOCFG: 25,16,0,0,1,0,0
+WIOCFG: 28,0,0,0,1,0,0
+WIOCFG: 29,0,0,0,1,0,0
+WIOCFG: 30,0,0,0,1,0,0
+WIOCFG: 31,0,0,0,1,0,0
+WIOCFG: 32,16,0,0,1,0,0
+WIOCFG: 33,16,0,0,1,0,0
+WIOCFG: 34,0,0,0,1,0,0
+WIOCFG: 35,0,0,0,1,0,0
+WIOCFG: 36,0,0,0,1,0,0
+WIOCFG: 37,0,0,0,1,0,0
+WIOCFG: 42,16,0,0,1,0,0


Now reboot and try your program again. I believe that GPIO is actually connected to the low power microcontroller on inside of the WP module. The above AT command gives ownership of the GPIO to the Linux CPU. You should just need to do this once.

Cannot get Heartbeat app to work

Thanks. That worked perfectly.