Possible to change default IP of device? (Solved) (Corrupt file system) (Final edit)


#1

[Final edit, found the real solution]

Despite reflashing several different firmware versions, I still wasn’t able to load even a hello world. After doing some off-forum troubleshooting with SW staff, it turns out the probable cause of problem was a corrupted file system caused by bugs in earlier firmware. After getting a new module sent to me, I am able to SSH into the WP8548 without any issues.

I’m posting this just in case anybody ever runs into the same issue. If anybody ever sees the following errors, consider that your file system may have been corrupted:

On the AT command interface:

At!entercnd="A710"
OK
At!usbcomp=1,1,8011D
ERROR
At!usbcomp?
Not Set

Using the serial port:

root@swi-mdm9x15:~# configEcm on
ecm not enabled
Could not create ecm configuration
root@swi-mdm9x15:~# configEcm show
ecm not configured
root@swi-mdm9x15:~# configEcm off
rm: can’t remove ‘/etc/dnsmasq.d/dnsmasq.ecm.conf’: No such file or directory
rm: can’t remove ‘/etc/legato/ecm.conf’: No such file or directory
ifconfig: down: error fetching interface information: Device not found
DONE

Original post and edits, no longer relevant

=========================================================================
Second edit:

For those who have not seen my earlier post, my main issue is that I am not able to successfully SSH into the Mangoh, but I can connect via serial. I am also able to successfully ping the device at it’s OS-assigned IP address from ipconfig (and ifconfig within the Ubuntu VM), but my local IT policy only allows us to SSH into devices within a specific IP range. Original details have been moved below to the dropdown.

Is it possible to change the IP address of the board (ECM IP according to the documentation) from 192.168.2.2 to another IPV4 address? I tried doing this from the connection IP properties menu as shown in the screenshot, but I believe I’m going to need to change the actual device properties.

=========================================================================
First edit:

I was having an issue with my SIM card which was causing the modem not to be recognized and not be assigned an IP address. Once I fixed my SIM issues, the board showed up in ipconfig and I was able to ping it from Ubuntu and Windows.

However, I’m getting a “connection refused” error when trying to SSH into root@192.168.2.2 from both Windows and Ubuntu.

There was another user with a similar problem (Connection Refused after firmware update), and the solution for them was another device on the network with a conflicting IP address. I’ve tried changing my board IP manually, and I can successfully ping the new IP, but still get refused when I try to SSH into it.

Has anybody else run into this issue?

=========Original Post==============

I’m trying to establish initial communications with the Mangoh green via USB and Putty, but I am not able to connect. It seems like putty is possibly connecting, but all I get is a blank console window that does not respond to any commands.

When connected via USB, the board does not respond to a ping of the default address 192.168.2.2 and ipconfig shows two mobile broadband connections that are disconnected and have no IP address. I did take out the WP module and verify that the arrows are aligned. The VM also can’t SSH into the board.

However, if I set up Putty as a serial connection into the NMEA port, I am able to log in and communicate via a serial to USB cable.

I am running the most recent generic firmware from the Sierra Wireless site, and I also installed the most recent drivers, which enumerate correctly in the device manager. My DIP switches are set in order from 1-8 to 10000000.

Does anybody have an idea of what could be keeping the board from communicating via USB?

Edit: I’m also pretty new to posting to technical forums like this, most times I’m able to find what I need by searching. Let me know if I should be including more or better information when I have questions like this.


#2

http://legato.io/legato-docs/latest/toolsTarget_configEcm.html


#3

Congratulations for figuring it out, but this is your real problem:

my local IT policy only allows us to SSH into devices within a specific IP range.

It’s totally counterproductive for a developer machine to be locked down like that.


#4

I agree! We’re in the process of figuring out workarounds until we can get an exception.