Ping 192.168.2.2: Doesn't work! (Step 3.2.9 in both User Guide & GSG (Linux))


#1

I’ve been working for four 10hr days to try get past Step 3.2.9 in the Starter Guides. Basic Ping to a WP7700 CF3 Module.

I suspect my dev environment is at fault but despite a lot of searching I cannot resolve the issue.

Win10 desktop with Ubuntu 16.04 in VirtualBox.
SierraWireless USB drivers installed on both Windows & Ubuntu-VM
From Windows w/o Ubuntu-VM running I can open cmd window and ping 192.168.2.2.
From VM - (qcserial, qmi_wwan blacklisted and GobiSerial & Net installed & running) I can always connect to /dev/ttyUSB0 or 1 (depending on how it enumerates) console port with moserial and login to the module.
I can NEVER get a response from Ping via the Ubuntu-VM.
I see both (two) USB devices in the VM: Sierra Wireless Sierra Wireless incorporated WP7700 [0318] and FTDI FT230X Basic UART [1000] in the VM so the ports are connected to the VM.

Just NO Ping (Ethernet via USB) connectivity to the module. Ahhhhh!!! :confounded:

A infoconfig -a cmd Yields;
enp0s11u1i8 Link encap:Ethernet HWaddr 2a:6c:e1:8f:34:4e
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

enp0s11u1i19 Link encap:Ethernet HWaddr ca:04:c4:04:89:be
inet6 addr: fe80::3c81:8cf0:2da9:d5a7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:120 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

dmesg effectively indicates that enp0s11u1i8 renamed from eth0 and enp0s11u1i19 renamed from usb0
…also:
[ 1041.405521] usb 1-1: New USB device found, idVendor=1199, idProduct=68c0
[ 1041.405524] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1041.405526] usb 1-1: Product: Sierra Wireless WP7700
[ 1041.405527] usb 1-1: Manufacturer: Sierra Wireless, Incorporated
[ 1041.405529] usb 1-1: SerialNumber: W881038511031015
[ 1041.413307] GobiSerial 1-1:1.0: GobiSerial converter detected
[ 1041.413395] usb 1-1: GobiSerial converter now attached to ttyUSB2
[ 1041.417183] GobiSerial 1-1:1.2: GobiSerial converter detected
[ 1041.417248] usb 1-1: GobiSerial converter now attached to ttyUSB3
[ 1041.423998] GobiSerial 1-1:1.3: GobiSerial converter detected
[ 1041.424072] usb 1-1: GobiSerial converter now attached to ttyUSB4
[ 1041.429120] QMAP Disabled
[ 1041.432308] GobiNet 1-1:1.8 eth0: register ‘GobiNet’ at usb-0000:00:0b.0-1, GobiNet Ethernet Device, 2a:6c:e1:8f:34:4e
[ 1041.435820] USB Speed : USB 2.0
[ 1041.450739] cdc_ether 1-1:1.19 usb0: register ‘cdc_ether’ at usb-0000:00:0b.0-1, CDC Ethernet Device, ca:04:c4:04:89:be
[ 1041.481633] cdc_ether 1-1:1.19 enp0s11u1i19: renamed from usb0
[ 1041.496966] GobiNet 1-1:1.8 enp0s11u1i8: renamed from eth0
[ 1041.520568] IPv6: ADDRCONF(NETDEV_UP): enp0s11u1i19: link is not ready

[ 1041.556615] IPv6: ADDRCONF(NETDEV_UP): enp0s11u1i8: link is not ready

WHAT am I missing? (clearly since this is still part of basic setup of the MangOH red it must be right in front of my face - so I can’t see it?)

Heeeelllllllllllllllllppppppppppppppppppppp!

Thanks,
Mike

a bit of more info


mbp@ubuntu:~$ sudo lshw -C network
[sudo] password for mbp:
*-network
description: Ethernet interface
product: 82540EM Gigabit Ethernet Controller
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:00:03.0
logical name: enp0s3
version: 02
serial: 08:00:27:8f:73:fa
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 66MHz
capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=192.168.0.112 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:19 memory:f0000000-f001ffff ioport:d010(size=8)
*-network:0
description: Ethernet interface
physical id: 1
logical name: enp0s11u1i8
serial: a2:da:60:da:63:72
capabilities: ethernet physical
configuration: broadcast=yes driver=GobiNet driverversion=22-Aug-2005 firmware=GobiNet Ethernet Device link=no multicast=yes
*-network:1
description: Ethernet interface
physical id: 2
logical name: enp0s11u1i19
serial: ca:04:c4:04:89:be
capabilities: ethernet physical
configuration: broadcast=yes driver=cdc_ether driverversion=22-Aug-2005 firmware=CDC Ethernet Device link=yes multicast=yes


#2

This used to happen to me as well and manually assigning the IP address would resolve this. Do the following:

sudo ifconfig enp0s11u1i19 192.168.2.3
and then try to ping 192.168.2.2.

This might resolve the issue.


#3

Thanks Devaiah. Will give it a go…
…why would ifconfig on 192.168.2.3 impact 192.168.2.2?


#4

Thanks Devaiah,
Since this is also usb0 could I map that (usb0) to 192.168.2.3?
alternatively I assume updating etc/network/interfaces.d with auto usb0 to that static IP is a more permanent patch? …or is this not recommended as it would clip usb0 in the VM to this particular function (a network device/port)?
Thanks again - mike


#5

I haven’t tried updating etc/network/interfaces.d. Maybe you could try doing that and if it works please post back here :slight_smile:


#6

(I meant the “interfaces” file, not “.d”).

Sadly as of yet nothing has worked:
I tried your ifconfig command for enp0s11u1i19 as well as usb0 (usb0 is not recognized) - NO-GO:
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
From 192.168.2.3 icmp_seq=1 Destination Host Unreachable
From 192.168.2.3 icmp_seq=2 Destination Host Unreachable
From 192.168.2.3 icmp_seq=3 Destination Host Unreachable

I also tried it in the “interfaces” file - and reset the VM. …same thing:
the ifconfig -a does show the mapping:
enp0s11u1i19 Link encap:Ethernet HWaddr 42:df:84:c8:2f:dc
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::40df:84ff:fec8:2fdc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

…at my wits end! :confused:


#7

Just an observation from my own setup.

I am using the same module with the same setup as you - WP7700, W10 + VM.
If my VM owns the USB device (can see ttyUSB in /dev) it never receives an IP and I can’t ping.
If my W10 owns the USB device (can’t see ttyUSB in /dev) it works fine.

I don’t know enough to offer an explanation for you, but it might be worth trying.


#8

Ha!!! Shib - that is indeed precisely it - late afternoon yesterday I was running through permutations of settings in an effort to learn something telling.

Who would think that disconnecting the USB port from the VM would allow the VM to ping through it? …completely counter-intuitive. Would like to understand why - but for now I will rock on forward - have some lost time to recover!

Although I discovered this same thing if I hadn’t I might never discover it and your ping would save me further aggravation.
Thanks shib and all who made an effort - much appreciated!


#9

As an add-on note: modifying /etc/network/interfaces to add the port (& static IP) is not required. Nor is sudo ifconfig enp0s11u1i19 192.168.2.3. These were all tangents w/no effect (at least for an Ubuntu-VM inside Win10).