PHP installation in WP[closed]


#1

Hi,

Please provide guidelines to build php package for WP. I added the below line to mdm9x15-image.inc

IMAGE_INSTALL_append = " php"

It gave me error on compilation due to package dependency. attached is the log file of the same. Let me know if I am missing anything.log.do_install.5820 (3.2 KB)

Thanks,
Hari.


#2

Hi Hari,

Please look at the following sites to get information on how to add packages to Yocto

https://wiki.yoctoproject.org/wiki/Building_your_own_recipes_from_first_principles
https://wiki.yoctoproject.org/wiki/How_do_I
This basically explains how to add custom packages to Yocto build.

Based on the log files, it seem like you are installing the host version of the PHP, is that what you really want? Or do you want to install it on the target?

regards,
Ashish


#3

Hi Ashish,

I want to install php on the target. What is the difference it makes on installing host version of php?

Thanks,
Hari.


#4

Hi @asyal

As suggested by Sierra Wireless FAE, Php is built successfully in the distro version Legato-Dist-Source-mdm9x15-SWI9X15Y_07.11.21.00.

Thanks,
Hari.