Permission denied (Public key)


I was setting up mangOH Yellow WP7702 and tried to connect to the mangOH yellow using the command ssh root@ on my terminal emulator.

I get the error:
Permission denied (Public Key).

When I was setting up my CF3 module for the first time, I chose option 1: Setup ssh keys and disable passwords-based authentication via ssh (the most secure) instead of option 3: Do Nothing.

How can I resolve this issue? Thanks in advance.

You can try to downgrade the FW to R11 and then use “swiflash -m wp77xx -r” to switch back to default state.

An example of WP76 module:


I tried to downgrade the firmware to R11, but the download failed because no download port was available. I ran the exe on Windows.

you can use 7zip tool to extract the exe.
Inside there is .spk file, transfer it to module /tmp folder by scp or USB thumb drive or download from network, and then you can use “fwupdate download /tmp/xxx.spk” command to update FW.

Besides, from your log, there is no download port.
You can also try AT!BOOTHOLD command to switch module to download mode.
Then you can try the exe again.
If it still not works, you can open command prompt, type “fdt2.exe xxx.spk” and see if it works.

Lastly, what is the current FW version on your module?
If it is on some FW older than R11, then you can directly use the swiflash to erase the userapp partition.

Thank you for your help. I have successfully downgraded my firmware to R11 and resolved the ssh key issue. My firmware version was 1.0.