Not work UART with IoT slot#0 on mangOH green

I bought RENFELL UART RS232-4W IoT card (0107-03-R2.1) and inserted it to IoT slot#0 on mangOH green.

I confirmed that WP76 module can detect this card by “dmesg | tail –n 22” command. But UART#1 did not work on IoT slot#0. Please let us know the correct procedure to activate UART#1 on IoT slot#0.


When I inserted Ether IoT card, it is working fine.

To confirm UART#1, I set AT!MAPUART=4,1 and am checking whether WP76 module can output NMEA message.

Should I use Mux control?

how about setting linux console to UART1?

My current setting is below.


!MAPUART: 4,17


But I did not see NMEA data with UART#1 on mangOH green IoT slot #0.

I already set the below but UART#1 on IoT Slot #0 did not work.


!MAPUART: 16,17


Did you disable flow control on host side?

Did the iot board work on mangoh red board?

I bought the following IoT slot card.

This doc is described as USB-serial. So, I understand that this IoT slot card do not work UART on WP76xx.

To run this USB-serial IoT slot card, I think that I should to install driver for USB-Serial converter IC. Then, I need to rebuild the kernel. But my module latest FW is R13.3 now. I do not find the R13.3 Linux distribution. Do you know the R13.3 Linux distribution?

You can download here,-d-,1-components/#sthash.2vlTNVx1.dpbs%201

To rebuild the kernel for WP76 module, do you know good tutorial?
I have leaf workspace.

Just extract it amd type “make”