Not connecting on SSHD


#1

I have a new mangoh board that I can’t connect to. I have tried to connect using the Developer Studio and a pop-up appears asking for the root password. Further, I’ve tried to connect via command-line "root@192.168.2.2" and tried to log into the device outside of the Developer Studio and I’ve received the same experience. Does anybody know how to reset the default password the WP750x (specifically a WP7504). The chips were Sierra Sample chips.
Thanks


#2

can u reflash the firmware and see?


#3

OK, Given that I’ve just started with mango, I’ve found the following:

http://source.sierrawireless.com/resources/airprime/software/legato_spm/

Since I am using a WP750X part not a WP85 part, I’m guessing that the file is somewhere else? I don’t want to brick my modem.


#4

Please use firmware from here:
http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/
It’s single click and wont brick your modem


#5

There has to be something magical that I am doing wrong. I’ve been using Linux and SSH for years and years. I have refreshed everything except the AT&T firmware. I started with a -r, then -i legato.cwe, then -i boot-yocto_p85.cwe, then -i mcufw_001.005.cwe. Everything I’ve read says that there is no “root” password. Therefore I hit return when it asks.

Every time I get:
root@link-Latitude-D630:/home/link# ssh 192.168.2.3
The authenticity of host ‘192.168.2.3 (192.168.2.3)’ can’t be established.
ECDSA key fingerprint is SHA256:mjfThNWxgk7avzDR78Gw7cjRZ8i6hPijDf8AXMJJ9Gw.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘192.168.2.3’ (ECDSA) to the list of known hosts.
root@192.168.2.3’s password:
Permission denied, please try again.
root@192.168.2.3’s password:
Permission denied, please try again.
root@192.168.2.3’s password:
Permission denied (publickey,password).
root@link-Latitude-D630:/home/link#

Any thoughts? Is the password stored in the last firmware module?


#8

Hi,
Can you tell me where you got the modules from?
There is no password for wp8 modules or wp7 modules. Need to understand the history of the modules so I can find out what is happening
regards,
Ashish


#9

I got them from Sierra Raleigh office they were actually sampled to me.

strangely on the Serial interface which I just hooked up:
root@swi-mdm9x15:~# run_getty.sh: UART2 (=/dev/ttyHS0) reserved for CONSOLE

Poky (Yocto Project Reference Distro) 1.7.3 swi-mdm9x15 /dev/ttyHSL1

swi-mdm9x15 login: root
root@swi-mdm9x15:~#

This means I am in. Do a dare change the password to nothing or will that really break things.


#10

well, that’s good progress…
BTW, why are you doing ssh at 192.168.2.3 and not 192.168.2.2?
You can also use ethernet interface to get the IP of the device and ssh through that.
use setNet [macrandom|macfixed] [dhcp|static] [address ] [netmask ]
to fix the IP of your board if you want. ( http://legato.io/legato-docs/latest/toolsTarget_setNet.html )
Not sure about the password change, as I have never done that.


#11

This is where it lands on my system. I am running Ubuntu 16.04. Can’t explain why sometimes it shows up one place and sometimes the other.

The actual problem is that I can’t download any code to it because it won’t let me log in using the Eclipse interface.


#12

I know there are some issues with ubuntu 16.04 ecm which could potentially be causing issues here.
You can use ethernet port to download code


#13

I guess I will try that. Strangely I changed the password and it appeared to change, but I don’t dare log out of serial terminal for fear of loosing contact completely. Let me try the Ethernet port. What IP address will it show up on?


#14

IP is random. You will need to look for it in the log messages on the serial port unless you use setnet to fix the IP


#15

It uses DHCP. Found it with “ifconfig -a” after logging in. Then logged in from my MAC.

I am not sure why I can’t log in via USB though. Very odd.


#16

Anyway, I am there. I can manage it myself. Thanks for your help. If I figure out why root@192.168.2.2 does not work, I will let you know.


#17

Great.
You can fix the IP using setnet btw. This way you dont need to look for the random IP all the time.