No satellites found & inaccurate LatLong with GPS antenna attached


#1

I just got a Taoglas AP.25M GPS antenna and have connected it to the GNSS port on the mangOH Red. When trying to write AT!GPSSATINFO? it returns NO SAT INFO OK. When trying to use le_pos_Get2dLocation it will still get valid positions (?), but is extremely wrong to current location. Any reason why it can’t seem to find any satellites, and will the position be more accurate if this get fixed?


#2

Are you testing inside your lab? Note, it is very difficult to get GPS when indoors.


#3

Yes, I am. Is it also difficult to find satellites indoors? @asyal


#4

yes, it is. You may want to take the unit outside for testing.


#5

Ok, do you think this will fix the wrongness in the position? I am currently in Tromsø, Norway which is around (69.65 , 18.93), and the GPS gets (65.80, 14.00) which is like 750km wrong :stuck_out_tongue:


#6

Also, there is a GPS repeater connected in the office. @asyal. So it is abit strange that it can’t seem to get that.


#7

Hi Lars,

The issue is that the GPS antenna you are using may not be working properly even with GPS repeaters in your office. Could you try a better one or try the test outside?

Regards,
Ashish


#8

Ok. I will try to test the device outside.


#9

I’ve now tested the device outside, and it still sends the same exact coordinates @asyal. It seems abit strange that is sends exactly the same coordinates every single time. It returns lat = 65800005 long = 13999999 every time.

I would like to point out that the log spits out every once a while:
Jan 11 09:24:44 swi-mdm9x15 user.warn Legato: -WRN- | posDaemon[807]/le_pa_gnss T=unknown | pa_gnss_qmi.c PositionHandler() 1123 | Bad position indication
and if I use result = le_pos_Get2DLocation(&latitude, &longitude, &horizontalAccuracy);it returns LE_OUT_OF_RANGE, but if i replace horizontalAccuracy with NULL, it goes back to sending the coordinate which is completely wrong and the same every time.

I’ve tried to run textLoc, and doesn’t find a gps position there either. I’ve tried the Sample code for Start/Stop GNSS device where at the end it tries to call le_gnss_GetTtff(&ttff), but doesn’t get any fix.

I’m a bit lost atm regards to why this isn’t working. Is there somthing I have forgotten to initialize for the GNSS or somthing?

Regards,
Lars


#10

Hi Lars,

For your information I started to play with mangOH Red GPS this morning and used the “Sample code for Fix On Demand” .
http://legato.io/legato-docs/latest/c_posSampleCodeFixOnDemand.html
This worked fine, had a fix (GPS antenna outside) after less than 2 minutes.

For this test I’m using a passive antenna:

How are things going on your side with GPS?

Gilles


#11

Hi Gilles

I am not able to get a GPS fix. The reason, I think, is that the device is not able to find any satellites at all. I’ve tried many times to use the AT commands like “AT!GPSSATINFO?” and it returns “NO SAT INFO OK” every time. I guess you can’t get a GPS fix without finding any of the satellites. I don’t really know why it will not find any.

Lars


#12
  • are you using a WP85?
  • Which GPS antenna are you using (do you have a datasheet)?
  • I think that just using an AT-command might not be enough, a “GPS service” needs to be started, that’s why I used the "Sample code for Fix On Demand” which is probably doing more. But I’m not an expert. You could give it a try (if you copy paste the code, you should remove the NMEA functions otherwise it won’t compile),

#13
  • Are you using a WP85? Yes
  • Which GPS antenna are you using (do you have a datasheet)? Taoglas AP.25M - datasheet: link
  • I will try running the test program on wednesday.

#14

I tried the “Sample code for Fix On Demand” now, and I still got the same problem with returning GPS-coordinates which does not change in number, and is completely wrong.


#15

Hi Lars,
OK this is strange.
Even with a passive GPS antenna I got a cold fix quite fast. Although you should be outside to do the fix.

  • Have you tried outside today?
    The fact that you get wrong results is probably due to the fact that the unit is not making a fix and you just get the default value of your variables, My test also displays incorrect GPS data until I get the good fix.
  • Do you get correct date and time with the “sample code for fix on demand”?
    Another thing could be that the GPS antenna doesn’t work probably or is damaged (can easily happen with those U.FL connectors).
  • Have you tried another GPS antenna?
    Gilles

#16

Hi Gilles

  • Yes. I tried it outside, and still got GetFixState: 0 on every one of them.
  • Yes, i get correct date and time
  • No, I have only tried this antenna.

Lars


#17

OK strange, coming out of ideas.
In a typical GPS fix, the GPS receiver first decodes time and date and then captures the position with more and more accuracy.
The fact that the target decodes time and date correctly seems to indicate that the GPS receiver is not completely dead and can make the first step. But then why no GPS fix?? Could there be something with GPS constellation showing less GPS satellites where you’re located (which would make it more difficult for the GPS receiver to make a fix)? Strange strange.


#18

If you see further up in this post, I am not able to find any satellites at all. Never been able to since i started to play around with it around 1.5 months ago


#19

Hi Lars
Gilles is correct that the sample code does work with active antenna. I had it working. However since Christmas, something stopped working. I have tried it on 5 Mangoh red boards and have not had a fix since. the only thing that changes with the LAF update from 17.07 to 17.10. I was told nothing in the update should have impacted a change. Even when I reverted, I was unable to get a lock. So I think there is something else that is causing the failure


#20

Hi guys,

I’m experiencing the same exact issues described by @larskarlsen. Any updates on this?, has this been moved to another thread?

Thanks in advance!