No response to "cm info" and related commands


#1

I was able to connect to the mangoh green and get a Hello World! example running, now I am trying to connect to a mobile network and

root@swi-mdm9x15:~# cm info
^C
root@swi-mdm9x15:~# cm radio
^C
root@swi-mdm9x15:~# legato version
16.10.1_a6a25fbda05738774857dccb9fd76a99_modified
root@swi-mdm9x15:~# fwupdate query
Connecting to service …
Error: can’t connect to service; is fwupdateService running?

I checked and the fwupdateService appears to be running.

Also trying to run the Legato Recovery Wizard crashes the developer studio application.


#2

Please update your firmware and then try again:
http://source.sierrawireless.com/resources/legato/wpfirmwarerelease13_1/

regards,
Ashish


#3

I ran the windows EXE and it completed no problems other than taking quite a long time. Issue still occurs.


#4


#5

Hello Csulz,

What i have noticed, if the APN name or/and authentication are not set correctly those commands take extremely long time to respond. Did you set those parameters?

Cheers,
tom


#6

So, when you first downloaded the windows exe, and tried cm info, it still hangs up? Or as Tom alluded to, did this happen after you entered the cm data apn command?


#7

There is no response to “cm info” or “cm data apn” commands. It responds to other commands after an escape but those don’t answer at all. What scale are we talking about “extremely long time” I waited a few minutes but maybe that is not long enough?

I have switched from the WP8548 to the WP7504 and everything is working there. I am in contact with the distributer about possibly getting a repair. But If I switch back I will let it go for longer.


#8

Ok. Seems more like an old/damaged WP8548 module.


#9

By extremely long time i meant ~10 seconds not minutes so it may be indeed some sort of hw failure.

BR
tom