New mangoRed can't ping and no console output - is it a DOA?


#1

USB ports appear to be enumerated to my VirtualBox VM:

  • Sierra Wireless,…WP7700 [318]
  • FTDI FT230X Basic UART [1000]

And the Green LED’s do illuminate (both top & bottom of PCB).

mbp@ubuntu:~$ ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
From 192.168.0.2 icmp_seq=1 Destination Host Unreachable
From 192.168.0.2 icmp_seq=2 Destination Host Unreachable
From 192.168.0.2 icmp_seq=3 Destination Host Unreachable

Never see any boot or power-up output in serial terminal.

Have checked and rechecked all steps and configuration settings multiple times. Never a response from Ping nor any output on the serial terminal.

Using moserial as serial terminal. Assuming 8N1, What is Baud rate?

I have not activated the SIM card yet - and I won’t until I can validate the Red modules is alive and I can Ping it.

Appreciate any input and next steps. I feel like I’m standing to close - all I see is bark so I can’t see any trees!

Thanks,
Mike


#2

Upon power-cycle using the jumpers with USB’s connected I do get Serial data out - garbled. This is indication of incorrect Baudrate. Updated to 115.2kbps and rebooted.

Now I am seeing Red boot console output (bottom).

Ping continues to fail as noted in first posting. Document indicates SIM card activation is not required for Ping. Is this correct? (or must the SIM card be activated?).

Serial console port output:
Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset), D - Delta, S - Statistic
S - QC_IMAGE_VERSION_STRING=BOOT.BF.3.1.2-00084
S - IMAGE_VARIANT_STRING=LAATANAZA
S - OEM_IMAGE_VERSION_STRING=jenkins
S - Boot Config, 0x000002e1
B - 1216 - PBL, Start
B - 3720 - bootable_media_detect_entry, Start
B - 5037 - bootable_media_detect_success, Start
B - 5042 - elf_loader_entry, Start
B - 8494 - auth_hash_seg_entry, Start
B - 32161 - auth_hash_seg_exit, Start
B - 83157 - elf_segs_hash_verify_entry, Start
B - 130163 - PBL, End
B - 119773 - SBL1, Start
B - 169702 - pm_device_init, Start
B - 187422 - PM_SET_VAL:Skip
D - 16439 - pm_device_init, Delta
B - 188764 - boot_config_data_table_init, Start
D - 30 - boot_config_data_table_init, Delta - (0 Bytes)
B - 197518 - CDT version:3,Platform ID:8,Major ID:1,Minor ID:0,Subtype:129
B - 204411 - sbl1_ddr_set_params, Start
B - 208254 - Pre_DDR_clock_init, Start
D - 213 - Pre_DDR_clock_init, Delta
D - 0 - sbl1_ddr_set_params, Delta
B - 220942 - pm_driver_init, Start
D - 4483 - pm_driver_init, Delta
B - 227225 - cpr_init, Start
D - 122 - cpr_init, Delta
B - 231800 - cpr_cx_mx_apc_vol_update, Start
D - 91 - cpr_cx_mx_apc_vol_update, Delta
B - 247019 - clock_init, Start
D - 152 - clock_init, Delta
B - 247263 - boot_flash_init, Start
D - 40107 - boot_flash_init, Delta
B - 748409 - boot_flash_swi_ddr_init, Start
D - 28822 - boot_flash_swi_ddr_init, Delta
B - 891545 - hw_family:5, hw_type:21, hw_rev:40
B - 892125 - cannot detect SSMEM base
B - 893345 - SSMEM bad, reinit
B - 897554 - SSMEM init OK
B - 918202 - opening partition 0:SWIFOTA
B - 918873 - error for readpage:0
B - 935130 - Failed to read size: /swinv/item_files/CUST_IM_SWITCH_HIDE
B - 940925 - Failed to read size: /swinv/item_files/FOTA_PARTITION
B - 941992 - Failed to read size: /swinv/item_files/CUST_IM_CONFIG
B - 955290 - ssmem_get: region 21 not exists
B - 962885 - ssmem_release: region 20 not exists
B - 962946 - ssmem_get: region 20 not exists
B - 968771 - Image Load, Start
D - 94825 - QSEE Image Loaded, Delta - (490996 Bytes)
D - 183 - boot_pm_post_tz_device_init, Delta
B - 1067988 - sbl1_efs_handle_cookies, Start
D - 0 - sbl1_efs_handle_cookies, Delta
B - 1076009 - DEVCFG ELF verification failure
B - 1079547 - Image Load, Start
D - 0 - SEC Image Loaded, Delta - (0 Bytes)
B - 1087233 - Image Load, Start
D - 55632 - RPM Image Loaded, Delta - (150424 Bytes)
B - 1142926 - Image Load, Start
B - 1145885 - Auth disabled for image 9
B - 1185382 - ssmem_get: region 20 not exists
D - 42517 - APPSBL Image Loaded, Delta - (378664 Bytes)
B - 1188646 - QSEE Execution, Start
D - 854 - QSEE Execution, Delta
B - 1195356 - SBL1, End
D - 1077931 - SBL1, Delta
S - Throughput, 8000 KB/s (1190772 Bytes, 135626 us)
S - DDR Frequency, 240 MHz
Android Bootloader - UART_DM Initialized!!!
[10] Qseecom Init Done in Appsbl
[10] secure app region addr=0x87900000 size=0x280000[10] TZ App region notif returned with status:0 addr:87900000 size:2621440
[20] TZ App log region register returned with status:0 addr:82679000 size:4096
[30] Qseecom TZ Init Done in Appsbl
[30] ERROR: No devinfo partition found
[30] Neither ‘config’ nor ‘frp’ partition found
[40] ERROR: No misc partition found
[1100] SSMEM init OK[1100] ssmem_get: region 20 not exists[1190] DEBUG: cmdline has root=
[1320] Channel alloc freed
[ 0.000000] GIC CPU mask not found - kernel will fail to boot.
[ 0.000000] GIC CPU mask not found - kernel will fail to boot.
[ 0.000000] MPM 1 irq mapping errored -517
[ 0.076675] SWI ssmem_framework_init: SSMEM init OK
[ 0.216137] spmi_pmic_arb 200f000.qcom,spmi: PMIC Arb Version-2 0x20010000
[ 0.231980] msm_mpm_dev_probe(): Cannot get clk resource for XO: -517
[ 0.235179] smd_channel_probe_now: allocation table not initialized
[ 0.243085] msm_thermal:msm_thermal_dev_probe Failed reading node=/soc/qcom,msm-thermal, key=qcom,online-hotplug-core. err:-517
[ 0.271577] msm_mpm_dev_probe(): Cannot get clk resource for XO: -517
[ 0.274606] msm_thermal:get_kernel_cluster_info CPU0 topology not initialized.
[ 0.275514] cpu cpu0: dev_pm_opp_get_opp_count: device OPP not found (-19)
[ 0.275533] msm_thermal:get_cpu_freq_plan_len Error reading CPU0 freq table len. error:-19
[ 0.276270] cpu cpu0: dev_pm_opp_get_opp_count: device OPP not found (-19)
[ 0.276288] msm_thermal:get_cpu_freq_plan_len Error reading CPU0 freq table len. error:-19
[ 0.276304] cpu cpu0: dev_pm_opp_get_opp_count: device OPP not found (-19)
[ 0.276317] msm_thermal:get_cpu_freq_plan_len Error reading CPU0 freq table len. error:-19
[ 0.370502] AXI: msm_bus_scale_register_client(): msm_bus_scale_register_client: Bus driver not ready.
[ 0.372295] AXI: msm_bus_scale_register_client(): msm_bus_scale_register_client: Bus driver not ready.[ 0.372587] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1343c8 OPER:0x00000090
[ 0.428668] msm_bus_fabric_init_driver
[ 0.648290] scm_call failed with error code -4
[ 0.648309] msm_audio_protect_memory_region: SCM call failed, scm_call_ret -95 tz_resp 0
[ 0.654105] uart_tx_gpio is not available
[ 0.654125] uart_rx_gpio is not available
[ 0.654145] uart_cts_gpio is not available
[ 0.654165] uart_rfr_gpio is not available
[ 0.654883] sps: BAM device 0x07884000 is not registered yet.
[ 0.660508] AXI: get_pdata(): Error: Client name not found
[ 0.660520] AXI: msm_bus_cl_get_pdata(): client has to provide missing entry for successful registration
[ 0.660528] msm_serial_hsl_probe: Bus scaling is disabled
[ 0.863574] mdm9607-pinctrl 1000000.pinctrl: pin GPIO_4 already requested by 78b0000.uart; cannot claim for 78b0000.serial
[ 0.874014] mdm9607-pinctrl 1000000.pinctrl: pin-4 (78b0000.serial) status -22
[ 0.881188] mdm9607-pinctrl 1000000.pinctrl: could not request pin 4 (GPIO_4) from group gpio4 on device 1000000.pinctrl
[ 0.892127] msm_serial_hsl 78b0000.serial: Error applying setting, reverse things back
[ 0.954358] sps: BAM device 0x07984000 is not registered yet.
[ 1.041957] unable to find DT imem DLOAD mode node
[ 1.046041] unable to find DT imem EDLOAD mode node
[ 1.051063] unable to find DT imem dload-type node
[ 1.055535] Failed to disable secure wdog debug: -4
[ 1.087481] devfreq soc:qcom,cpubw: Couldn’t update frequency transition information.
[ 1.095626] sdhci_msm 7864900.sdhci: sdhci_msm_pm_qos_parse_irq: error -22 reading irq cpu
[ 1.107107] coresight-tmc 6025000.tmc: failed to get flush cti
[ 1.112503] coresight-tmc 6025000.tmc: failed to get reset cti
[ 1.181655] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
[ 1.203489] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
[ 1.211420] wl12xx GPIO: 131
[ 1.233088] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
[ 1.255054] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
[ 1.263926] calculate_residency: residency < 0 for LPM
[ 1.268028] parse_cpu_levels: idx 1 420
[ 1.280511] calculate_residency: residency < 0 for LPM
[ 1.284623] parse_cpu_levels: idx 2 500
[ 1.300155] parse_cpu_levels: idx 2 3040
[ 1.304100] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
[ 1.320716] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
Setting up IMA subsystem…
IMA is not supported.
The proc node does not exist
mount root fs from partition (rootfs|system)
Non-secure.
[ 1.503743] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
UBI device number 0, total 120 LEBs (30474240 bytes, 29.1 MiB), available 2 LEBs (507904 bytes, 496.0 KiB), LEB size 253952 bytes (248.0 KiB)
[ 1.894517] mdm9607-asoc-snd soc:sound-wm8944: Defering mdm_asoc_machine_probe, q6_state 0
rootfs roothash: e66529f349e057e9e314b2ece1516cd2adc87b1b46209d1cfb25550d1fb4cb16
rootfs: dev ‘/dev/ubiblock0_0’ ‘squashfs’
mount /dev/mapper/rt
rootfs: mounting took 0ms

init started: BusyBox v1.24.1 (2018-02-19 00:41:11 UTC)
rcS: Executing mount_essential_fs…
rcS: Executing simple_network…
rcS: Executing run_S_scripts…
S02mount_early: Executing mount_early_pseudo…
S02mount_early: Executing mount_early_other…
S02mount_early: Executing mount_early_create_dirs…
S02mount_early: Executing yaffs2_kern_supported_init…
S02mount_early: Executing mount_early_user_start…
S02mount_early: RO rootfs fudge allowed.
S02mount_early: User is forcing userapp file system to be ubifs.
S02mount_early: Trying to mount UBIFS on /mnt/flash using [usrquota,grpquota,rw] mount options…
UBI device number 3, total 524 LEBs (133070848 bytes, 126.9 MiB), available 5 LEBs (1269760 bytes, 1.2 MiB), LEB size 253952 bytes (248.0 KiB)
S02mount_early: Performing quota check on file system mounted at /mnt/flash
S02mount_early: UBIFS volume successfully mounted on /mnt/flash
S02mount_early: Executing mount_early_legato_start…
sh: 200: unknown operand
mount Legato from partition lefwkro
S02mount_early: Non-secure.
UBI device number 2, total 35 LEBs (8888320 bytes, 8.5 MiB), available 0 LEBs (0 bytes), LEB size 253952 bytes (248.0 KiB)
S02mount_early: SQUASHFS successfully mounted on /mnt/legato
S02mount_early: Executing mount_early_userrw_start…
S02mount_early: Mounting swirw file system as UBIFS
S02mount_early: Trying to mount UBIFS on /mnt/userrw using [usrquota,grpquota,rw] mount options…
UBI device number 4, total 100 LEBs (25395200 bytes, 24.2 MiB), available 2 LEBs (507904 bytes, 496.0 KiB), LEB size 253952 bytes (248.0 KiB)
S02mount_early: Performing quota check on file system mounted at /mnt/userrw
S02mount_early: UBIFS volume successfully mounted on /mnt/userrw
S02mount_early: swirw mounted to /mnt/userrw
S03confighw.sh: Kernel internal entropy pool filler is available, increasing write_wakeup_threshold to 3072
Starting system message bus: dbus.
S07mount_unionfs: RO rootfs fudge allowed.
Mounting local filesystems…
[ 8.506595] UBIFS error (pid: 464): cannot open “ubi0:usrfs”, error -19mount: mounting ubi0:usrfs on /usr failed: No such device
sh: 200: unknown operand
mount modem from partition modem
MTD : Detected block device : /firmware for modem

UBI device number 1, total 128 LEBs (32505856 bytes, 31.0 MiB), available 0 LEBs (0 bytes), LEB size 253952 bytes (248.0 KiB)
Initializing random number generator…
Switching to composition sierra_dev (1199:68C0)
[ 8.901990] enable_store: android_usb: already disabled
Configuring network interfaces… done.
Starting syslogd/klogd: done
Starting diagrebootapp: ifconfig: SIOCGIFFLAGS: No such device
done
$Starting qcom_time:
starting time-daemon
Starting time_services: done
Legato start sequence
restart_at_uart: Mapped UART1 for AT service
[ 12.769514] i2c-msm-v2 78b8000.i2c: msm_bus_scale_register_client(mstr-id:86):0xb (ok)
[ 12.839341] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x001363c8 OPER:0x00000090
Finished Legato start Sequence
Starting reboot daemon: done
Starting atreset: done
Starting modem dependent daemons: [ 17.994688] M-Notify: General: 7
[ 18.007720] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route MM_DL5 -> MultiMedia5 -> TERT_MI2S_RX Audio Mixer
Load modem done
Starting qmuxd: [ 18.053020] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route MM_DL8 -> MultiMedia8 -> TERT_MI2S_RX Audio Mixer
done
[ 18.080404] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route INT_FM_TX -> INTERNAL_FM_TX -> SEC_MI2S_RX Port Mixer
Starting thermal-engine: [ 18.139700] diag: In diag_send_feature_mask_update, control channel is not open, p: 0, c1073884
done
[ 18.304943] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for MM_UL28
Starting irsc_util: [ 18.430236] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route MultiMedia28 Mixer -> direct -> MM_UL28
Starting irsc tool
Failed to open file:/etc/sec_config
Absent/Invalid config,Default rules apply
Ending irsc tool
done
[ 18.481688] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for MM_UL29
[ 18.489156] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route MultiMedia29 Mixer -> direct -> MM_UL29
Starting netmgrd: [ 18.571824] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route VOICEMMODE1_DL -> VoiceMMode1 -> SEC_MI2S_RX_Voice Mixer
done
[ 18.607317] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route VOICEMMODE2_DL -> VoiceMMode2 -> SEC_MI2S_RX_Voice Mixer
[ 18.657818] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL28 MUX
Starting fs-scrub-daemon: 18.704861] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route PRI_MI2S_TX -> PRI_MI2S_TX -> AUDIO_REF_EC_UL28 MUX
[ 18.750487] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL28 MUX
[ 18.759121] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route SEC_MI2S_TX -> SEC_MI2S_TX -> AUDIO_REF_EC_UL28 MUX
done
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
[ 19.107342] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL28 MUX
rm: can’t remove ‘/var/log/wtmp’: No such file or directory
[ 19.210864] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route TERT_MI2S_TX -> TERT_MI2S_TX -> AUDIO_REF_EC_UL28 MUX
Starting qmi_ip: [ 19.325149] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL28 MUX
[ 19.398976] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route QUAT_MI2S_TX -> QUAT_MI2S_TX -> AUDIO_REF_EC_UL28 MUX
done
[ 19.525548] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL29 MUX
[ 19.600004] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route PRI_MI2S_TX -> PRI_MI2S_TX -> AUDIO_REF_EC_UL29 MUX
[ 19.665352] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL29 MUX
[ 19.703604] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route SEC_MI2S_TX -> SEC_MI2S_TX -> AUDIO_REF_EC_UL29 MUX
[ 19.791475] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL29 MUX
starting DNS forwarder and DHCP server: dnsmasq… 19.817823] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route TERT_MI2S_TX -> TERT_MI2S_TX -> AUDIO_REF_EC_UL29 MUX
[ 19.849192] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for AUDIO_REF_EC_UL29 MUX
[ 19.875084] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route QUAT_MI2S_TX -> QUAT_MI2S_TX -> AUDIO_REF_EC_UL29 MUX
[ 19.908438] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no source widget found for AUDIO_REF_EC_UL3 MUX
done.
[ 19.925555] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route AUDIO_REF_EC_UL3 MUX -> direct -> MM_UL3
[ 19.944805] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no source widget found for AUDIO_REF_EC_UL28 MUX
[ 19.971329] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route AUDIO_REF_EC_UL28 MUX -> direct -> MM_UL28
Starting Dropbear SSH server: [ 20.019791] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no source widget found for AUDIO_REF_EC_UL29 MUX
[ 20.070463] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route AUDIO_REF_EC_UL29 MUX -> direct -> MM_UL29
DONE
[ 20.141926] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route SEC_MI2S_TX -> SEC_MI2S_TX -> SLIMBUS_0_RX Port Mixer
cat: can’t open ‘/sys/devices/virtual/android_usb/android0/f_ecm/native_ethaddr’: No such file or directory
dropbear.
[ 20.168998] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route VOICE2_STUB_DL -> Voice2 Stub -> INTERNAL_BT_SCO_RX_Voice Mixer
stopping DNS forwarder and DHCP server: dnsmasq… [ 20.212120] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: no sink widget found for SENARY_MI2S_TX
[ 20.243284] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: Failed to add route BE_IN -> direct -> SENARY_MI2S_TX
stopped /usr/bin/dnsmasq (pid 1037)
done.
Starting port_bridge: starting DNS forwarder and DHCP server: dnsmasq… done
done.
run_getty.sh: ttyHSL1 reserved for CONSOLE

Poky (Yocto Project Reference Distro) 2.2.2 swi-mdm9x28 /dev/ttyHSL1

swi-mdm9x28 login: [ 20.975735] msm-pcm-routing soc:qcom,msm-pcm-routing: ASoC: mux SLIM_0_RX AANC MUX has no paths
[ 21.018367] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-dtmf-tx: ASoC: no sink widget found for STUB_DTMF_TX
[ 21.060472] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-dtmf-tx: ASoC: Failed to add route DTMF TX -> direct -> STUB_DTMF_TX
[ 21.090467] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-rx-capture-tx: ASoC: no sink widget found for STUB_HOST_RX_CAPTURE_TX
[ 21.117657] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-rx-capture-tx: ASoC: Failed to add route CS-VOICE HOST RX CAPTURE -> direct -> STUB_HOST_RX_CAPTURE_TX
[ 21.138217] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-rx-playback-rx: ASoC: no source widget found for STUB_HOST_RX_PLAYBACK_RX
[ 21.150970] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-rx-playback-rx: ASoC: Failed to add route STUB_HOST_RX_PLAYBACK_RX -> direct -> CS-VOICE HOST RX PLAYBACK
[ 21.166620] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-tx-capture-tx: ASoC: no sink widget found for STUB_HOST_TX_CAPTURE_TX
[ 21.179615] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-tx-capture-tx: ASoC: Failed to add route CS-VOICE HOST TX CAPTURE -> direct -> STUB_HOST_TX_CAPTURE_TX
[ 21.195303] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-tx-playback-rx: ASoC: no source widget found for STUB_HOST_TX_PLAYBACK_RX
[ 21.208478] msm-dai-stub-dev soc:qcom,msm-dai-stub:qcom,msm-dai-stub-host-tx-playback-rx: ASoC: Failed to add route STUB_HOST_TX_PLAYBACK_RX -> direct -> CS-VOICE HOST TX PLAYBACK
[ 21.841626] adm_callback: cmd = 0x10322 returned error = 0x16
[ 21.846339] adm_callback: ADM map error, resuming
[ 21.851658] adm_memory_map_regions: DSP returned error[ADSP_ERR_MAX]
[ 21.857362] adm_map_cal_data: map did not work! cal_type 0 ret -68
[ 21.863811] map_memory: map_cal failed, cal type 10, ret = -19!
[ 21.869430] adm_alloc_cal: cal_utils_alloc_block failed, ret = -19, cal type = 10!
[ 21.877200] call_allocs: alloc failed!

Poky (Yocto Project Reference Distro) 2.2.2 swi-mdm9x28 /dev/ttyHSL1

swi-mdm9x28 login: