mqttClient Service Connect error?

and why you say me to use it? :grinning:
Is there a way to see on the terminal if my board can “talk” with mqtt mosquitto broker at the adress tcp://192.168.2.3:1883?

you are the one decide to use mosquitto , I never ask you to use it

As said before you need to wireshark to capture the traffic

I can also use AirVantage broker at the adress tcp://eu.airvantage.net:1883, but the situation doesn’t change :disappointed_relieved:

you can debug in MQTTClient_connectAll() and see why it returns SOCKET_ERROR

but what have I to debug if this function works well for other users on the forum? I really don’t understand why all is so difficult with this HW

I read this post:

This guy uses mosquitto (so I’m not the only one person to use it in the universe :grinning:) and he has the same problems on the connection, but the solution is not clear

other user can work with MQTT:

I read this:


Could be this the problem? And is not clear where have I to insert these options in my SW (in .adef?)

you need to ask that user, I did not modify that configuration.

Believe me, I’m sorry, but it’s a tragedy with this HW, everything seems very difficult, it’s a nightmare. I can’t wait to change my project, abandon it and never see it again in life

Why don’t you do debug in MQTTClient_connectAll() for further analysis?
Why don’t you capture wireshark on server side?

I try, but I already know it will not lead to any results. Thanks so much for your help

To be honest, that will not help…
What if your next project is still difficult, are you going to abandon it again?
You need to have proper skill and passion to progress.
You said that you tried and conclude that will not lead to any result, but I wonder if you really tried with wireshark …
i.e.
Here at least i can receive the MQTT message in port 1883 with WP76 FW R13:

So probably your MQTT server is not responding which makes the problem.

Thanks so much for the reprimand. But I see that Mosquitto should be active …

Again that won’t help …

Why don’t you do debug in MQTTClient_connectAll() for further analysis?
Why don’t you capture wireshark on server side?

Besides just activating the server, you need to think more ways to debug!!!

As said above, other user had made it work before

So, I try to rearrange the ideas. The code does not work due to connection problems with the broker. Downstream of the analyzes made today, I am even more convinced that this is the case. Also because, seeing in the old posts (from a month ago) I had exactly the same problem when I unknowingly compiled other people’s code, only that I thought it was a software problem (maybe I didn’t understand something) and then I put myself in a some sense to develop it alone (albeit based on that). So I wonder (and I ask you): having a communication problem with port 1883 (almost certainly) is there a guide to correctly enter a broker on Ubuntu in order to communicate with mangOH through port 1883?
I hope I was clear …

I don’t want to give the impression of being a slacker, I understood and debugged the code, for me it seems to work well (statistically, by the way, it can only be so, since even when I use other people’s code I have exactly the same problem! ). The problem is definitely on port 1883. In fact I INSTALLED WIRESHARK (I also sent you a screenshot a few hours ago) and it clearly shows that only the mangOH on port 22 is detected and nothing else. If there is something else below, unfortunately I do not have the skills to understand it, I am little more than a student, therefore quite ignorant.

seems your wireshark is not capturing USB ECM interface…
It should be something like this:

You might also give a try on Mosquitto windows version.

Do you think it could be a problem of configuration file? I installed mosquitto using sudo apt-get mosquitto install, then I can see that mosquitto is running with mnosquitto status:


isn’t it enough to make mosquitto (or in general a broker) running on Ububtu VM?

I don’t know, that is why you need to get evidence to prove which part is going wrong