Micro SD Support on MangOH

I am trying to use Micro SD card in MangOH board. I have 8 gb sandisk / samsung micro sd card but not detecting. Please let me know supported SD card type and size.


Hi Niladridm,

Have you used the mux command to select routing SDIO to the MicroSD card slot? Specifically the command is mux 9. Try running that command and then insert your MicroSD card. Please report back to let me know if this solves your problem or not.


Thank you dfrey. can you please let me know how do I execute this command? is this terminal command or AT command?


I have tried to execute this command in Terminal and AT Shell but both the case it is showing invalid command.

Hi Devid,
After installing Mux Control Service and tools along with Gpio Expander Service I am able to execute mux 9 command and getting a response that “Executing 9: Select the microSD Card on the SDIO mux Success” but I am unable to find my sd card in the /dev. please let me know how to mount the sd card? ls /dev/sd* - is returning nothing to me


are you using SD card provided in the dev kit?

Hi Ashis,
no it is 8gb sandisk class 4 microsd. Tried with FAT16 and FAT32 format but not detecting.

Can you check the one that was shipped with the board first? Not all uSD work with mangoh. We have seen some issues with some SD cards and think most likely it is related to the TI as uSD card multiplexer.

Also, please wait for release 12 firmware (to be released soon) as that should have part of your uSD problem fixed.

Hello Niladridm,

I opened a ticket on this forum and WP Series forum about SD card problems (not quite the same problem).

I am pleased to see that the next version (version 12) may solve problems because my post went unanswered.

For SD card detection with release 11:
load driver:

insmod /lib/modules/3.14.29ltsi-c14b887744_39dcf2256d/kernel/drivers/mmc/host/msm_sdcc.ko

Mount device (example)

mkdir -p /mnt/userrw/sdcard
/bin/mount -t auto -o sync /dev/mmcblk0p1 “/mnt/userrw/sdcard”


Hi spastor,
Thanks. Good to know that you are able to mount the sd card.
I am able to load the driver without any issue and selected the SDIO using mux 9 even in my board Jumper setting is also proper but still I am unable to see mmcblk0p1 in dev. Dont know whats is the wrong. I have tried with 8gb Transcend, Sandisk and Strontium microSd card Fat16 and Fat 32


Have you tried the SD card the came with the dev kit?

HI Ashish,
Unfortunately I lost the sd card and reader too which came along with the kit. Hope release 12 will support different make and size of SD card. Anyway if you share me the make and model supported by release 11, I shall try to get one.


Hi Nila,
Ill send you a list of cards that work tomorrow.
Release 12 will not fix the issue you see, as it due SD mux used on DV4. It seems to cause issues with some SD cards.

I tried the following two cards that I had available with me today:

http://industrial.apacer.com/en-ww/SSD/Industrial-microSD-R1 (1Gb version)

Both of them worked.

Hi Ashish,
I have tested with different SD card and below are working good

  1. PNY 4GB
  2. Strontium 4GB/8GB
  3. Samsung 4GB/8GB


1 Like

thanks for the update

You can add SanDisk Ultra Plus microSDXC UHS-I 64Gb as working also… Could imagine the whole SanDisk SDXC line might work, now is there a limitation on size???

mmc0: host does not support reading read-only switch. assuming write-enable.
[ 16.966915] mmc0: new high speed SDXC card at address aaaa
[ 16.997375] mmcblk0: mmc0:aaaa SL64G 59.4 GiB
[ 17.103555] mmcblk0: p1
[ 17.254143] sps:BAM 0x12502000 is registered.
[ 17.257897] enable_store: android_usb: already disabled

1 Like