MediaTek WiFi on SPI [Solved]

#1

Has anyone tried using the Wifi using SPI? I can get the Wifi to work with UART but I need this port for some other stuff. I have flashed the WIfi to work using SPI but the init script uses UART. Any help would be appreciated

Unable to have stable Wifi with MT7697 over UART or SPI
#2

@asyal anything from your side?

#3

Did you try changing the /etc/network/interfaces section for the wifi interface to pass “spi” instead of “uart” to the mtwifi script? I haven’t used wifi over spi in quite a while, but I did use it at one time. The problem is that the wifi is significantly slower on spi compared to uart.

#4

Thank you. I feel kinda stupid now. Its working

#5

Hello @asifarshad,

I have flashed the WIfi to work using SPI

could you quickly recap for me what you did to enable Wifi over SPI?
I wanted to try that too, but I’m not sure if/how I have to change the firmware.

#6


Follow the above steps but change the build files as explained below

At the end where you pass uart to wifi in mtwifi script and then scp it to mangoh.
It should work fine

#7

Remember for SPI:
SWI_SPI_ENABLE (should be = y)
SWI_UART_ENABLE (should be = n)

#8

Thank you @asifarshad, that worked indeed! :+1: