MangoRed Audio error


#1

Hello All,
I’m trying to play audio file using aplay and getting bellow error.

root@swi-mdm9x28-wp:~# aplay Front_Center.wav
aplay: Playing ‘Front_Center.wav’:Signed 16 bit Little Endian 1208.513686] q6asm_srvc_callback: cmd = 0x10d92 returned error = 0x16 sid:1

[ 1208.522542] q6asm_memory_map_regions DSP returned error for memory_map [ADSP_ERR_MAX]
[ 1208.530016] q6asm_audio_client_buf_alloc_contiguous: CMD Memory_map_regions failed -68 for size 128
[ 1208.539275] q6asm_memory_unmap: Do not send null mem handle to DSP
[ 1208.545802] Audio Start: Buffer Allocation failed rc = -22
[ 1208.550972] msm-pcm-dsp soc:qcom,msm-pcm: ASoC: soc:qcom,msm-pcm hw params failed: -12
[ 1208.558652] MDM Media1: ASoC: hw_params FE failed -12
Aplay:cannot set hw params[ 1208.566789] q6asm_callback: cmd = 0x10bcd returned error = 0x16

Aplay:params setting failed
[ 1208.572252] __q6asm_cmd: DSP returned error[ADSP_ERR_MAX] opcode 68557
[ 1208.581119] BUG: sleeping function called from invalid context at /work/kernel/kernel/locking/mutex.c:97
[ 1208.590513] in_atomic(): 0, irqs_disabled(): 128, pid: 3676, name: aplay

Thanks & Regards,
Mallikarjuna Reddy


#2

Some questions:

  1. WP76 or WP77?
  2. Which firmware version are you using?
  3. Have you tried other wav files? Same result or different?

#3

Hey dfrey,

       Thanks for support.
      
     1. WP76 or WP77?
     Ans. WP7702
    2. Which firmware version are you using?
    Ans. Legato release 7
    3. Have you tried other wav files? Same result or different?
    Ans : I've tried multiple files, but i got same result.

#4

I guess it seems WP77 does not have the audio function.


#5

> 2. Which firmware version are you using?
Ans. Legato release 7

Do you mean WP77xx Release 7? That was released in January, 2018 and since then Release 8, 9 and 9.1 have been done. I’m not saying that this will definitely fix your problem, but is there a reason why you’re not using the latest release?


#6

Hi dfrey,

Thanks for your response.

The mangoH red board, which i bought, came with default Legato release 7.

Do you suggest any latest releases, where audio(ALSA) works…?

Thanks & Regards,
Mallikarjuna Reddy