Mangoh Yellow Wifi app only iPV6

Hi All,

I was playing around with wifi app and I always got an ipv6 address after connecting to an AP. Maybe I am missing something but I could not make ipv4 working.

Any idea?


I have a mangOH Red with a WP7700, and if I plug in a DUB-E100 Ethernet adapter into the USB host port, it gets an ipv6 address only. Perhaps this is a global issue with interfaces not just wifi.

Hi @tomalex,
I’m unsure of the commands you are using to start the wifi app. By default for
the recently released yellow’s and all to follow, i.e. board rev. DV4. The wifi app
has been disabled by setting in the config tree wifiService to manual start. Note,
if you set in the config tree wifiService to auto then the DCS service will pre-test
wifi on every boot. Anyways, it will help to know what command you used. I’ll
give you my commands that I just ran to manually start:
app start wifiService
wifi client start
wifi client scan
wifi client setsecurityproto 0x4a1 3
wifi client setpassphrase 0x4a1 MY_SECRET
wifi client connect 0x4a1
/sbin/udhcpc -R -b -i wlan0
root@swi-mdm9x28-wp:~# ip --oneline address show wlan0
10: wlan0 inet brd

I think the issue is with your router/AP, it must be assigning V6 addresses.
Also you can play with the udhcpc scripts & settings to see the interplay with
your AP/router:

Good luck and let us know if you still have problems or if you found your solution.


Hi Zahid,

Thank you for your answer. Unfortunately, I made a step backwards. :confused:
I have installed the official WP77XX package with the following command:
“swiflash -m “wp77xx” -i WP77xx_Release12_SIERRA.spk”
After that I have tried to install the Mangoh Yellow Sytem that I recompiled without Octave.
“update yellow.wp77xx.update”
Actually, I had to remove two applications as they caused a reboot (Buzzer, Light) . It might be related to the fact that the wifi does not work at all anymore.

After “wifi client start” I receive the following errors in log:
wifiStartIssue.txt (9.0 KB)

Do you have any idea what kind of mistake I could have done? Do you know how to go back to default system what the mangoh yellow originally had?

Thank you for your help I really appreciate it!

You are using the wrong software.
Please check the mangoh yellow getting started guide or download the .spk to your unit from
This will bring you back to the default state.

Hi @asyal,
Thanks for your answer!
I was using the mangOH-yellow-wp77xx_0.2.3 package in leaf, and I also tried to install the yellow_wp77xx_0.2.3.spk from mangohIO but it seems not to be a “clean” install and the same problem persist.

The closest I got to clean start:
As the swiflash -m “wp77xx” -r was not working (.ERROR: Firmware Download failed. Callback status 59399ERROR) I installald release11.spk and reseted the user partion after that I installed the yellow spk, but still the same problem…
It can be I made somewhere an amateur mistake but I really don’t see it right now.

Thanks for your help!

swiflash -m wp77xx -i  spkname

Maybe It was not clear what I wrote. I did exaxtly that " swiflash -m “wp77xx” -i yellow_wp77xx_0.2.3.spk"
After that wifi still does not start and gives this strange errors in log: “can’t insert ‘/legato/systems/current/modules/brcmfmac.ko’: File exists”
What i did after that i tried to use the -r option but it did not work on this release. ( Callback status 59399ERROR) that is why I installed release 11 where I used the option -r.

Thanks for the help,

Is this production hardware or the giveaway hardware?

We received the board last week on Sierra Summit. (I guess it is then the prodcution type). We have an other board to test with and will order new ones but it would be good to know what is going on.

can u show the complete log file?

  1. power up the unit
  2. app start wifiService
  3. wifi client start


  1. Log with Mangoh “yellow_wp77xx_0.2.3.spk” Image
    syslog_mangohYellowSPK.log (842.1 KB)

2.Log with WP77xx_Release12_SIERRA.spk + Latest Mangoh Yellow Build without Octave and without Buzzer, Light apps
syslog_MangohBuildWithoutOctave.log (441.1 KB)

On the Mangoh Yellow we have not changed anything from “base” setup, just enabled the external SIM slot with AT commands.

Thanks again for your help!

can you physically power cycle the unit and send me the logs again? Do you have any external devices connected to the yellow?

There were no external devices connected, and I used a high power USB. I have just talked with my colleague an he ended up with the same issue after installing a Mangoh Build without Octave. I think it has something to do with mixing up something on the filesystem. Swiflash -r does not work (only with WP77 release 11 but no difference) I will send you the new logs in PM.
Thanks a lot, tom

We tried all our units but didn’t use swiflash -r and didn’t run into any issue. Need to find out what the issue is with swiflash -r