mangoH yellow ULPM

If i use AT!POWERWAKE=2,38,5 devices shutsdown but never awake… it become blind to GPIO38… shaking have no effect at all. Also leds stop blinking. Only way to wakeup is poweron with button .

almost desperate…

i cant see any resolution to issue QTI9X06-192 … nor workaround i can use…

g.

Did you compile the bmi160 driver?

You might also try original gpio36 test and see if it blinks

Where i can download latest yellow firmware? So i can restore also original firmwware for mangoh?

Have you tried “leaf search”?

Using latest mangoH yellow firmware from here:

Mangoh Yellow latest firmware is a little bit older than Rel. 14.1

root@swi-mdm9x28-wp:~# cm info
Device: WP7702
IMEI: 352653090386178
IMEISV: 5
FSN: 4L033685021210
Firmware Version: SWI9X06Y_02.35.02.00 5208b3 jenkins 2020/06/10 00:30:12
Bootloader Version: SWI9X06Y_02.35.02.00 5208b3 jenkins 2020/06/10 00:30:12
MCU Version: 002.014
PRI Part Number (PN): 9909138
PRI Revision: 001.010
Carrier PRI Name: SIERRA
Carrier PRI Revision: 001.036_001
SKU: 1104405
Last Reset Cause: Reset, User Requested
Resets Count: Expected: 151 Unexpected: 0

Anyway… no changes. No way to put in in ULPM and WakeUp. I’m asking if someone ever succeded… cause on forum seems noone found a way…

…also AT+CPSMS=0 fails… ERROR

Jeremy can you share the solution that worked for you?

Regards
Gianmaria

Probably you need to solder a wire to gpio36 or gpip38 to change the state and see if this can wake up the module in ulpm mode

This can isolate the problem in bmi160

Maybe i have to review the driver for BMI160 and see if INT1 is enabled…and linked to some events (es. significat motion). And see if registers are set in the right way to keep config during ULPM.
I’m sure INT1 is physically linked to GPIO38… we review the schematics a lot of times.

Gian

from the schematic, GPIO36 is connecting to the light sensor’s interrupt.
And gpio38 is connecting to the BM160’s interrupt.
Not quite sure whether you shake the board is really related to the BMI160 as previously you are using GPIO36 for wake up pin…

Hi,

We have abandoned the wake-up on GPIO. We now use wake up on ADC2 which serves us as wake up on GPIO: 0 or 1

Best Regards,
Jeremy

Thanks anyway. I found my problem is in driver. On default .ko INT1 is not enabled.